ML 270 seems underpowered

sarge955

Member
Joined
Jul 3, 2012
Messages
13
Reaction score
0
Location
Nottingham, England
Your Mercedes
2008 clc 350
My ml 270 has developed a fault. it seems very underpowered and wont rev above 3000 rpm. sounds sweet enough and the fuel economy is unusually good. no smoke from the exhaust or lights lit up on the dash.

Any ideas????
 

gizze

Senior Member
Joined
Sep 2, 2008
Messages
2,574
Reaction score
23
Location
Norfolk
Your Mercedes
5 Series Touring + 911 Carrera 4
You need a new Mass Air Flow Sensor.

£60 from Mercedes.

Takes 2 minutes to fit.
 

tony jr

Senior Member
Joined
May 5, 2009
Messages
581
Reaction score
9
Location
Nottingham
Your Mercedes
GL320 X164 2007
Sounds like you are in limp-home mode (which would also prevent kick down) - this could be caused by a variety of reasons such as a faulty MAF sensor (as said above), blocked EGR valve, swirl flaps sticking on the inlet manifold, spilt turbo pipe or something as simple as small cracks in the rubber connectors of the vaccum lines allowing leaks in the system. I would check all of the rubber joints in the vaccum lines and also look for any slit hoses first. If they are ok then have the fault codes read to home in on the problem
 

gizze

Senior Member
Joined
Sep 2, 2008
Messages
2,574
Reaction score
23
Location
Norfolk
Your Mercedes
5 Series Touring + 911 Carrera 4
The MAF Sensors do tend to go around 10 years old though, pretty much like clockwork.
If it hasn't been replaced already then may as well do that first.

Turn the car off and lock it, then get in and start it, without moving or changing gear, rev it in neutral, does it hit 3000rpm and that's it?
If so I would definitely say the MAF.
 

rjevon

Senior Member
Joined
Apr 1, 2009
Messages
320
Reaction score
1
Location
Staffordshire
Your Mercedes
ML 270 CDi 2002
I have a spare MAF that I purchased to diagnose a fault.

The MAF was not at fault and is in a box in the garage.

for the cost of postage I can send it on if required, I also have an ignition switch.

Regards
Richard
 

rjevon

Senior Member
Joined
Apr 1, 2009
Messages
320
Reaction score
1
Location
Staffordshire
Your Mercedes
ML 270 CDi 2002
I have a spare MAF that I purchased to diagnose a fault.

The MAF was not at fault and is in a box in the garage.

for the cost of postage I can send it on if required, I also have an ignition switch.

Regards
Richard

Or you could collect it as I work in Derby if thats of any use.

Dont want any money for it as I've sold my ML and wont be buying another.

Richard
 

tony jr

Senior Member
Joined
May 5, 2009
Messages
581
Reaction score
9
Location
Nottingham
Your Mercedes
GL320 X164 2007
You could try cleaning the MAF sensor with some isopropanol electrical contact cleaner. Sometimes oil mist from the breather pipe affects the performance of the sensor. Simple to do. just remove the air box lid undue the 2 torx screws holding the sensor in place. twist and pull the sensor out. Spray end with contact cleaner and then put it all back together. You might find it cures the problem. if it does then at least you know it's the MAF that is the problem.
 

Steve@Avantgarde

Forum Supporter
Authorised Forum Supporter
Joined
Dec 8, 2009
Messages
7,107
Reaction score
1,467
Location
Bristol/Somerset
Website
www.avantgarde-automotive.co.uk
Your Mercedes
C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
I would get it on STAR diagnosis before you commit to anything. Get some fault codes and see what the trouble is. Not unless you like a guessing game.
 

tony jr

Senior Member
Joined
May 5, 2009
Messages
581
Reaction score
9
Location
Nottingham
Your Mercedes
GL320 X164 2007
I agree with Steve - there are many conditions other than the MAF sensor that will put the car into limp home mode.
 
OP
S

sarge955

Member
Joined
Jul 3, 2012
Messages
13
Reaction score
0
Location
Nottingham, England
Your Mercedes
2008 clc 350
  • Thread Starter
  • Thread starter
  • #11
Or you could collect it as I work in Derby if thats of any use.

Dont want any money for it as I've sold my ML and wont be buying another.

Richard
That would be brilliant cheers mate. I am on nights this week but if i could meet up next week that would be brill and if dosnt work then i'll just get the codes read.

Thanks again

Sarge
 
OP
S

sarge955

Member
Joined
Jul 3, 2012
Messages
13
Reaction score
0
Location
Nottingham, England
Your Mercedes
2008 clc 350
  • Thread Starter
  • Thread starter
  • #12
That would be brilliant cheers mate. I am on nights this week but if i could meet up next week that would be brill and if dosnt work then i'll just get the codes read.

Thanks again

Sarge
On second thoughts could you post it to me please. My email address is
sarge955@hotmail.co.uk if you send me your address I will post you a cheque for the postage and give you my address. Have just been out in my break and cleaned the sensor and now it revs ok so looks as though that is the problem.

Many thanks again

sarge
 

rjevon

Senior Member
Joined
Apr 1, 2009
Messages
320
Reaction score
1
Location
Staffordshire
Your Mercedes
ML 270 CDi 2002
sarge,

MAF posted yesterday. Did give it the wife to post, but found it on the dash of her car !!

Richard
 

Frontiersman11

New Member
Joined
Jan 26, 2015
Messages
6
Reaction score
0
Location
SOUTH WALES UK
Your Mercedes
C250 CDI AMG SPORT 2011 + W163 ML 270 CDi 2001
ML270 Underpowered and no kick down.

Have been reading various threads on this problem, and will try the cures suggested to Sarge955. However just in case I need the codes read, can anyone please recommend a MB specialist in South Wales? I am near Tredegar NP225BD. Need one for future servicing anyway. Cheers.
 

You lost your key ? Or maybe you need a spare! Your vehicle imobilliser does not respond anymore? WE CAN FIX THEM ALL !! Mobile ! Save Time and Increase Profits With us !
Top Bottom