ML270 cdi possible problem

gwilson

Member
Joined
Feb 28, 2009
Messages
12
Reaction score
0
Hi all,

Ive recently brought a ML270 CDI on a 51 plate.

There does not appear to be any kickdown and its struggling to accelerate pass 80 mph.

The previous owner did mention that the battery had been recently replaced, after reading another thread saying the MAF plug is located close to the battery I'd like to check this before I phone a garage.

Where is the plug and could someone stick a photo up of what I am looking for.

Can anyone recommend a Indie mechanic in the Glasgow area.

Thanks

Gareth
 
OP
G

gwilson

Member
Joined
Feb 28, 2009
Messages
12
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Television,

I disconnected that plug as suggested. Managed a max rpm of 2600 and approx 65mph that was foot to the floor.

When I reconnected it the acceleration was markedly improved however there isnt a significant kickdown, ie motorway cruising at 70 put foot down and nothing happens just a very slow increase in speed.

I dont think the plug was properly connected to start with as when I went to disconnect, it felt loose. When I reconnedted it went in with a good click and felt a lot more solid.

Thanks for your help.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
These things can behave like this when faulty, a new one from a Bosch service center is the cheapest, I think that you will find that it will slip back again
 
OP
G

gwilson

Member
Joined
Feb 28, 2009
Messages
12
Reaction score
0
  • Thread Starter
  • Thread starter
  • #5
thank you very much. Is there a part number that I need on it?
 


AMF Automotive - We are an independent Mercedes-Benz and AMG specialist located in Dartford, with full Mercedes Diagnostic equipment. We offer a full portfolio of tuning options for AMGs and can cater for all your Mercedes needs.
Tel: 0203 384 4644www.amfmercedes.com/
Top Bottom