ML270 very sluggish to pull off then ok

PRM1

Senior Member
Joined
Dec 10, 2006
Messages
47
Reaction score
0
This is a 2002 ML270 which has been fine until the weekend.

When the car is cold it crawls out of the drive and there seems to be no response when giving it a bit more throttle.

Then after it pulls out onto the main road it's all back to normal and drives off fine.

Only has 53,000 miles and next service not for another 8500 miles.

Any ideas what to look for as it needs a few things done soon anyway.

Thanks in advance
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Thats a strange one Paul, and normally it is the MAF but not in your case, as the symptoms are backwards :confused: :confused:
 
OP
P

PRM1

Senior Member
Joined
Dec 10, 2006
Messages
47
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
I drove the car around 120 miles on saturday no issues just flew long fine.
Sunday morning very sluggish couple of mins then fine all day. Now the same again today and my wife moaned about the same yesterday.
Very odd.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Wait till one of the techies read the post, they should be able to help
 
OP
P

PRM1

Senior Member
Joined
Dec 10, 2006
Messages
47
Reaction score
0
  • Thread Starter
  • Thread starter
  • #5
just to bump up the list as it is still not right.
 

kebo57

Senior Member
Joined
Oct 4, 2006
Messages
894
Reaction score
3
Location
Lanc's
Your Mercedes
ml270
just to bump up the list as it is still not right.
Hi might need more information

Is your motor an auto
if so then can you use the tiptronic (change down to first gear) as you crawl out of the drive
what about the engine rev's, crawls with high revs our crawls with low revs that are equal to the slow speed

Kevin
 

jibcl500

Senior Member
Joined
Oct 22, 2005
Messages
6,420
Reaction score
6
Age
53
Location
Cambridgeshire
Your Mercedes
CL500,ML55,SLK280
Id say the Air mass sensor, had and ML in last week with the same fault wouldnt go over 2000 rpm for a while then whosh its off as normal, sensor is less than £60 and is a service item.
Best get some diags done to be sure.
jib
 
OP
P

PRM1

Senior Member
Joined
Dec 10, 2006
Messages
47
Reaction score
0
  • Thread Starter
  • Thread starter
  • #8
yes auto, when you drive off it seems to keep the revs and speed are low. Then it the revs increase and off we go as normal.
 

The Rock

Senior Member
Joined
Oct 18, 2006
Messages
155
Reaction score
0
Location
Dan Sarf
Could it be something as simple as the throttle position sensor playing up when it's cold/damp?

Just a guess.
Rock
 

The Rock

Senior Member
Joined
Oct 18, 2006
Messages
155
Reaction score
0
Location
Dan Sarf
Another idea I've had is leaky Exhaust Gas Recirculation pipework, perhaps???. That can cause strange behaviour on cold (and hot) engines i.e. lack or loss of power.

I do agree that cleaning the MAF and the inside of its surrounding pipework is never a bad idea. Carefully, of course.

Rock
 

BLK

New Member
Joined
Apr 9, 2009
Messages
8
Reaction score
0
I have the same problem with my C220 Cdi W203. In a morning it drives like a slug for about a mile then off it goes as though nothing was ever wrong!

The fault occured immediately after I had the heater plugs replaced (genuine MB, and right part). Took it back to the garage and they tested it on star. No fault reported, so nothing was done. All heater plugs are working fine. Nothing else was done with the vehicle at the time of changing heater plugs.

It just seemed strange that the fault is cold engine related and it occured IMMEDIATELY AFTER the heater plugs were replaced. Any thoughts / solutions?
 
OP
P

PRM1

Senior Member
Joined
Dec 10, 2006
Messages
47
Reaction score
0
  • Thread Starter
  • Thread starter
  • #13
Sorry for the delay replying.

The car has been fixed and is now super smooth.

It was the number 3 injector over fuelling. Changed this and all sorted.

Thanks to everyone at M.B.Specialist Ltd - Bridgend S Wales. Best service from a garage for years. www.mbspecialists.co.uk
 
Gtechniq manufactures an ultra durable and comprehensive range of surface protection products for cars, boats, RV's and aircrafthttp://www.gtechniq.com
Top Bottom