New member with hopefully an old problem.

AndyMAcfarlane

New Member
Joined
Apr 7, 2021
Messages
3
Reaction score
1
Your Mercedes
1992 190E
Hello folks! Nice to be here!
I just thought I'd ask a wee technical problem. I recently bought a 190E (1992 model) from a friend of mine. It runs great most of the time, but... now and again the power just drops. As if I'd taken my foot off the accelerator. And I can get it to "reset" so-to-speak by turning the ignition key off and on a click. When it starts happening it usually keeps happening until I stop her and try later on. I once made it 100miles home on the motorway using this trick and swearing. (I HAD to get home)
I have replaced OVP and fuel rump relays, my mechanic has changed the spark-plugs and says the fuel filter is relatively new and clean. Strangely though, that's the 2nd time I've changed the spark-plugs in 6 months and what with Covid restrictions, I haven't been driving much.
Obviously this problem doesn't show up when I take it to my mechanic so he's got no idea where to start.
Any suggestons?
 

andrew056

Senior Member
Joined
Jun 7, 2010
Messages
113
Reaction score
18
Location
Devon
Your Mercedes
1993 SL320 gone but not forgotten , 2004 240 CLK cabrio, 2006 ML 320cdi gone, GLC AMG 43
It sounds to me as if it could be the ignition control module breaking down , it can only really be lack of fuel or lack of sparks and as it resets that would indicate an electrical problem.
Good luck Andrew
 
OP
A

AndyMAcfarlane

New Member
Joined
Apr 7, 2021
Messages
3
Reaction score
1
Your Mercedes
1992 190E
  • Thread Starter
  • Thread starter
  • #3
It sounds to me as if it could be the ignition control module breaking down , it can only really be lack of fuel or lack of sparks and as it resets that would indicate an electrical problem.
Good luck Andrew
Cheers! I'm over in italy so I'll translate that as best I can for my mechanic!
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,256
Reaction score
15,660
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
Have you checked the ignition switch itself? If you have a bad contact the simple switching off and on may be enough to remake the contact which then eventually unmakes again and so on.
If you have a heavy bunch of keys try removing them just leaving the ignition switch and see if that helps.
 
OP
A

AndyMAcfarlane

New Member
Joined
Apr 7, 2021
Messages
3
Reaction score
1
Your Mercedes
1992 190E
  • Thread Starter
  • Thread starter
  • #5
Have you checked the ignition switch itself? If you have a bad contact the simple switching off and on may be enough to remake the contact which then eventually unmakes again and so on.
If you have a heavy bunch of keys try removing them just leaving the ignition switch and see if that helps.
Interesting point. The problem surfaced the day after my keys would'nt turn in the ignition and had to do some serious jiggling of keys and locked steering wheel to finally release them. I never thought to link the two events together. And yes, I do have a rather heavy bunch of keys and keyring.
I luckily have a whole new ignition barrel and set of keys too.
 

You lost your key ? Or maybe you need a spare! Your vehicle imobilliser does not respond anymore? WE CAN FIX THEM ALL !! Mobile ! Save Time and Increase Profits With us !
Top Bottom