No radio reception Command

mingblus3

Senior Member
Joined
Oct 2, 2009
Messages
83
Reaction score
0
Was fine last night, today just got a hissing sound. The CD player works and the sound is fine. The TV works but the sound is the hissing crackling sound again.

The only thing i did last night was to reset the blower / actuators. Now this morning my ****** radio is not working. Every day i start the car up there is a new problem.

I might as well also point out that my new navigation disc is also stuck in the head unit and it won't eject. Nor am i picking up satellites still. Are there any tips on removing the disc, though I'd ask at the same time.


Regards

Simon
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Where does one start. the fact that a disc is stuck in means that the eject mechanism will have to be fixed,,it is a known fault and firms do this,,at the same time other thing could be checked.

If the sound on CD is OK then the output stages in the Comand are OK,,If the TV works but the sound is hissy then it is set for the wrong country it should be on PAL I

The radio could be a antenna amp problem

The no SATs is probably the antenna
 

Avantgarde Automotive, Mercedes-Benz and SLR McLaren specialists. Service, repairs, diagnosis and motorsport preparation.
Unit 14 Hither Green Trading Estate, Clevedon, Somerset, BS21 6XU Tel: 01275 217270 Email:steve@avantgarde-automotive.co.uk
www.avantgarde-automotive.co.uk
Top Bottom