Noise after turning engine off with smoke vito

hotbiker

New Member
Joined
Sep 27, 2009
Messages
7
Reaction score
0
Hi i have just driven 20 or 30 miles quiet quickly and when i got home i turn off engine and there was a loud aeroplane like noise that got quieter and quieter but there was alotta smoke produce from some where. i have a vito 110 2.2 cdi ( i am new to this so sorry if i have done it wrong) cheers Phil:p
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Welcome to the forum at this late or early hour, depending on your life style ;):D

If you have an AUX air pump,it could be that if the car drove OK and no loss of power.
 
OP
H

hotbiker

New Member
Joined
Sep 27, 2009
Messages
7
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
hi thank you i am always up late i am a dj which is wot i use the van for hehe absolute no loss of power it pulls string wot would an aux air pump be used for and where would i find it? thank you again
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
The pump if fitted just keeps the emissions under control and can run when the engine is turned off, normally right on top and the front of the engine
 

LYNALL

Senior Member
Joined
Aug 7, 2003
Messages
315
Reaction score
0
Location
Kent
I would say block or auxiliary heater especially as you say there was smoke.



Lynall
 
OP
H

hotbiker

New Member
Joined
Sep 27, 2009
Messages
7
Reaction score
0
  • Thread Starter
  • Thread starter
  • #6
but it has been fine since and has lost no power?
 
OP
H

hotbiker

New Member
Joined
Sep 27, 2009
Messages
7
Reaction score
0
  • Thread Starter
  • Thread starter
  • #7
but does still have the noise
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Well the stationery heater does not run when you are driving, and you have to turn it on when you are parked up
 
OP
H

hotbiker

New Member
Joined
Sep 27, 2009
Messages
7
Reaction score
0
  • Thread Starter
  • Thread starter
  • #9
hi i have had a look underneath the van and found a box with a very small exhaust attached to it and thats where the smoke came out of any ideas is this the air compressor you spoke of? :D if so is that used to cool the turbo? do you think my van is ok or is this normal? cheers phil
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
hi i have had a look underneath the van and found a box with a very small exhaust attached to it and thats where the smoke came out of any ideas is this the air compressor you spoke of? :D if so is that used to cool the turbo? do you think my van is ok or is this normal? cheers phil

I think that is the stationery heater :shock:
 
OP
H

hotbiker

New Member
Joined
Sep 27, 2009
Messages
7
Reaction score
0
  • Thread Starter
  • Thread starter
  • #11
how do i turn that on and off then there are no switches i can see cheers phil
 

Shawz89

New Registration
Joined
Sep 4, 2012
Messages
1
Reaction score
0
Location
Bristol
Your Mercedes
Vito
I also have this problem help would be great thanks.
 


Chris Knott Insurance, see oursticky posts here!
www.ckinsurance.co.uk
Top Bottom