1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Parking sensors

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Dell, Apr 23, 2018.

  1. Dell

    Dell Senior Member

    Messages:
    242
    Likes Received:
    59
    Joined:
    Feb 14, 2010
    Location:
    Warwickshire
    Your Mercedes:
    2015 C class C220 CDI Coupe silver
    hi all
    I have a fault with my rear parking sensors,when I select reverse four red lights come on and it beeps for about 10 seconds but do not work, anyone had this problem and could point me in the right direction.?
     
  2. JBell

    JBell Senior Member

    Messages:
    11,413
    Likes Received:
    3,334
    Joined:
    Dec 9, 2011
    Location:
    Torquey
    Your Mercedes:
    C350 CDi Estate (GAD Edition)
    You have a failed sensor, you need it diagnosed to find out which one.

    If you have a W204 series car the part number is A2125420018

    They are numbered

    Parking sensor numbers 1.png
     
    Dean Fletcher and Dell like this.
  3. OP
    Dell

    Dell Senior Member

    Messages:
    242
    Likes Received:
    59
    Joined:
    Feb 14, 2010
    Location:
    Warwickshire
    Your Mercedes:
    2015 C class C220 CDI Coupe silver
    Thanks JBell
    Just to clarify would 1 sensor make both sides do the same thing ?and do I have to remove rear bumper to change them? Also will unplugging them one at a time show me the faulty one?.
    Or is it a star job?.
     
  4. JBell

    JBell Senior Member

    Messages:
    11,413
    Likes Received:
    3,334
    Joined:
    Dec 9, 2011
    Location:
    Torquey
    Your Mercedes:
    C350 CDi Estate (GAD Edition)
    Yes, one faulty sensor will turn the whole lot off

    No, you can reach up and pull them out, easier if the car is on a ramp though

    Apparently you can listen to them and if it is clicking it is faulty, I had my car plugged into a Delphi decoder and it identified which one was faulty by the number so just changed that one.
     
    Dell likes this.
  5. OP
    Dell

    Dell Senior Member

    Messages:
    242
    Likes Received:
    59
    Joined:
    Feb 14, 2010
    Location:
    Warwickshire
    Your Mercedes:
    2015 C class C220 CDI Coupe silver
    According to what I have seen on tinternet it is the other way round,if it is not clicking it is faulty,I have checked my car and three are clicking but one is not so I have ordered one will change it and see.
    The local garage wanted £60 to diagnose it a bit executive I think.
     
    Dean Fletcher and JBell like this.
  6. Craiglxviii

    Craiglxviii Senior Member

    Messages:
    14,439
    Likes Received:
    3,759
    Joined:
    Sep 6, 2015
    Location:
    Cambs UK
    Your Mercedes:
    W215 CL500 Motorway Queen; W251 R320L Familybenz, S211 E320 Avg Designo Edition now sadly missed.
    £60 is a standard fee for Star...
     
  7. LostKiwi

    LostKiwi Senior Member

    Messages:
    23,438
    Likes Received:
    12,644
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    Unless you want to drop by mine....;)
     
    Dean Fletcher and Dell like this.
  8. OP
    Dell

    Dell Senior Member

    Messages:
    242
    Likes Received:
    59
    Joined:
    Feb 14, 2010
    Location:
    Warwickshire
    Your Mercedes:
    2015 C class C220 CDI Coupe silver
    Thanks for the offer LostKiwi I may take you up on that but I will see if the new one I ordered fixes the problem first.


    Craiglxviii the local garage uses a standard scanner not star.
    Dell
     
  9. JBell

    JBell Senior Member

    Messages:
    11,413
    Likes Received:
    3,334
    Joined:
    Dec 9, 2011
    Location:
    Torquey
    Your Mercedes:
    C350 CDi Estate (GAD Edition)
    Should still be able to find out which one
     
  10. Carl Gosney

    Carl Gosney Member

    Messages:
    10
    Likes Received:
    1
    Joined:
    Apr 10, 2010
    Location:
    Warrington/Cheshire
    Your Mercedes:
    E-CLASS E250 CDI 7G-TRONIC BLUEEFFICIENCY SPORT SALOON
    Right found out why my sensors dont work on the back of my merc ....
     
  11. Andy.M

    Andy.M Senior Member

    Messages:
    903
    Likes Received:
    132
    Joined:
    Feb 20, 2012
    Location:
    Rochester Kent
    Your Mercedes:
    2014 GLA250 Premium Plus, Night, AMG Exclusive Leather, Driving Assistance Packs COMAND DAB HK Audio
    Waits with bated breath.........
     
  12. OP
    Dell

    Dell Senior Member

    Messages:
    242
    Likes Received:
    59
    Joined:
    Feb 14, 2010
    Location:
    Warwickshire
    Your Mercedes:
    2015 C class C220 CDI Coupe silver
    Well back to square one tried new sensor still not working so tried new sensor in the other three plugs still no joy,so not the sensors so I need to find a local Indy to sort it.
     
  13. JBell

    JBell Senior Member

    Messages:
    11,413
    Likes Received:
    3,334
    Joined:
    Dec 9, 2011
    Location:
    Torquey
    Your Mercedes:
    C350 CDi Estate (GAD Edition)
    Check the sensor, I bought one off E-Bay and it didn't work so got the electronix one and it worked, you do need to diagnose to make sure you are replacing the correct one
     
  14. Trev1964

    Trev1964 Senior Member

    Messages:
    282
    Likes Received:
    65
    Joined:
    Jan 26, 2017
    Location:
    Oldham
    Your Mercedes:
    Slk 2006 350
    Symptoms do point to a sensor.
    My SLK had same issue.
    My carsoft told me which had failed and i replaced it. All works good now.
    Needs reading. All sensors are not created equal. Some of the cheap ones are not good.
     
  15. OP
    Dell

    Dell Senior Member

    Messages:
    242
    Likes Received:
    59
    Joined:
    Feb 14, 2010
    Location:
    Warwickshire
    Your Mercedes:
    2015 C class C220 CDI Coupe silver
    The sensor I got is a genuine one according to bo, made by Bosch.
     
  16. Trev1964

    Trev1964 Senior Member

    Messages:
    282
    Likes Received:
    65
    Joined:
    Jan 26, 2017
    Location:
    Oldham
    Your Mercedes:
    Slk 2006 350
    Just got to get it read then hopefully.
    A silent sensor is bad. A clicking one is not necessarily good though.
    I've come unstuck with that one inthe past.
     
  17. OP
    Dell

    Dell Senior Member

    Messages:
    242
    Likes Received:
    59
    Joined:
    Feb 14, 2010
    Location:
    Warwickshire
    Your Mercedes:
    2015 C class C220 CDI Coupe silver
    Hopefully getting it tested this weekend but today it worked for an instant that to me points to a dodge connection or wiring fault.
     
  18. Trev1964

    Trev1964 Senior Member

    Messages:
    282
    Likes Received:
    65
    Joined:
    Jan 26, 2017
    Location:
    Oldham
    Your Mercedes:
    Slk 2006 350
    Mine would intermittently work. Got rarer and rarer though.
    One bad sensor on rear took the whole system down.
     
  19. JBell

    JBell Senior Member

    Messages:
    11,413
    Likes Received:
    3,334
    Joined:
    Dec 9, 2011
    Location:
    Torquey
    Your Mercedes:
    C350 CDi Estate (GAD Edition)
    They do that, it is a faulty sensor
     
    Dell likes this.
  20. OP
    Dell

    Dell Senior Member

    Messages:
    242
    Likes Received:
    59
    Joined:
    Feb 14, 2010
    Location:
    Warwickshire
    Your Mercedes:
    2015 C class C220 CDI Coupe silver
    Fitted new non genuine sensor yesterday all working fine now,thanks everyone who helped.
    Strange thought why a new genuine sensor was faulty but sent it back should get refund soon.
    Dell
     
    Dean Fletcher likes this.

Share This Page