R129 no bass from speakers

r129co

MBO Forum Supporter
Authorised Forum Supporter
Joined
Jan 17, 2006
Messages
176
Reaction score
9
Age
69
Location
Kent
Website
r129.co
Your Mercedes
R129 SL500
I have a 1996 SL320....it does not have a Bose system.
there is no response from the main speakers in either door..just the tweeters.
I have tried different Becker amps under the rear seat and it makes no difference...it also makes no difference unplugging the amp or plugging it in.
Any ideas?
 

Robbostanhill

Senior Member
Joined
Dec 22, 2011
Messages
602
Reaction score
0
Location
Dartford, Kent, UK
Your Mercedes
E270 Estate 2003 and *Her* C220 W203
Naturally you've tried setting the bass on the radio etc ?
Using a small battery (Penlight cell or button type) make a link wire from the battery and "flash" the terminals on the speakers. This should give you a sound from them as you do it. Don't use anything heavier voltage as it may destroy them entirely. If they work and make noise then work back to the connection at the amp, using the same process see if the speakers make a noise. If they do then they are fine and the cables are connecting.
 
OP
r129co

r129co

MBO Forum Supporter
Authorised Forum Supporter
Joined
Jan 17, 2006
Messages
176
Reaction score
9
Age
69
Location
Kent
Website
r129.co
Your Mercedes
R129 SL500
  • Thread Starter
  • Thread starter
  • #3
Will do...wonder why they both have failed tho?
 

Bolide

Senior Member
Joined
Sep 17, 2002
Messages
3,294
Reaction score
4
Website
www.w124.co.uk
Your Mercedes
BMW 525 Diesel Touring
Pull the speakers out and check them with a voltmeter. They should be around 4 Ohms. If they are o/c they're blown

They've probably been overdriven and have popped

Nick Froome
 
OP
r129co

r129co

MBO Forum Supporter
Authorised Forum Supporter
Joined
Jan 17, 2006
Messages
176
Reaction score
9
Age
69
Location
Kent
Website
r129.co
Your Mercedes
R129 SL500
  • Thread Starter
  • Thread starter
  • #5
Merci
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
later 129 speakers are all 1 ohm, if you use too high an impedance the sound output will be much reduced. they cost £100 each from MB
 
OP
r129co

r129co

MBO Forum Supporter
Authorised Forum Supporter
Joined
Jan 17, 2006
Messages
176
Reaction score
9
Age
69
Location
Kent
Website
r129.co
Your Mercedes
R129 SL500
  • Thread Starter
  • Thread starter
  • #7
Ah thanks...are you a new boy Television..haven't seen you in these parts for a while!
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Ah thanks...are you a new boy Television..haven't seen you in these parts for a while!

Yes a newbie as from yesterday

You can test a speaker for good/ bad with a 1.5 volt battery, with the battery in one direction the cone will move forward and in the other it will move back.

Do not do this with tweeters though.
 
OP
r129co

r129co

MBO Forum Supporter
Authorised Forum Supporter
Joined
Jan 17, 2006
Messages
176
Reaction score
9
Age
69
Location
Kent
Website
r129.co
Your Mercedes
R129 SL500
  • Thread Starter
  • Thread starter
  • #9
Solid as ever
 

Comand Online Ltd is a specialist supplier of Mercedes Navigation Disks, Phone & Bluetooth, iPod, DAB, CD and other COMAND retrofit parts to enhance your vehicle.www.comandonline.co.uk
Top Bottom