1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Relay making noise on the trunk after driving for an hours.

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by tasinga2, Aug 31, 2010.

  1. tasinga2

    tasinga2 Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Apr 1, 2010
    Location:
    halifax
    Your Mercedes:
    merc C240, 2001,2.6L
    Hello, this is my first time to use this site, I realy wish someone could help me sort this problem out. I've been to the dealer they can't find the problem.

    Everythings is working fine after one hour of driving, I starting noticing that, the fuel gauge running low fast then normal to empty tank, when i'm 100% sure still plenty of fuel in the tank.

    Follow by indicator light, bothside not flashing but remain permanent,including the hazard light.

    Once I stop, I am unable to open the trunk automaticaly, unable to lock the car via remote control in 1 metre radius. To do that I must get close to the driver's door in less then a metre to lock/unlock the car.

    At the same time all these apening you could clairly hear the tickling noise comming from the left fuse box in the trunk, also the service light at the back of rhe car keep flashing everytime. the Relay in question is in second position from top to bottom after the fuel pompe relay. I replaced the relay but nothing change. Once the car's parked for two hours everything back to normal again.

    I don't know what to do right now, Can someone pls tell me why all this happening and what to do to make it better.

    I would be very much apreciated any help you may offer.

    Thanks.
     
  2. Supercharged

    Supercharged Senior Member

    Messages:
    800
    Likes Received:
    0
    Joined:
    Jun 18, 2010
    Location:
    Somewhere in East Yorkshire
    Your Mercedes:
    New Audi RS5 Coupe on order
    Hi and welcome to the forum , someone with technical knowledge will be able to answer your question ....... Hang fire
     
  3. Cole@MBS

    Cole@MBS Forum Supporter Authorised Forum Supporter

    Messages:
    13,533
    Likes Received:
    602
    Joined:
    Dec 1, 2008
    Location:
    Hedge End, Southampton
    Your Mercedes:
    124 300 CE 24 Coupe, 209 240 CLK
    Rear SAM controls fuel gauge and rear lights etc, you need it to go on star for a code read but guessing the rear SAM is u/s

    welcome to the forums!
     
  4. OP
    tasinga2

    tasinga2 Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Apr 1, 2010
    Location:
    halifax
    Your Mercedes:
    merc C240, 2001,2.6L
    relay making noise in the trunk

    Thanks guys, That's exactly what was in my mind. I took it off anyway and tried to open it, which wasn't easy but I managed, In side i could not find any hardware fault in all the part. The problem as you have show, is nothing more than a software issue. As a detective i'm suspecting one of the bigest chip which's defenetly a processor with 64pin, made by Motorola. with ref: MC68HC908AZ60Y. i'm just trying to find out where to buy this chip also if it's possible to reprogram the MCU. by luck i find this place. www.codecard.it this guy sell all the chip for all the car, wish me luck.

    I will let you know what happen before i run to maindealers.

    ****** german lol.
     
  5. OP
    tasinga2

    tasinga2 Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Apr 1, 2010
    Location:
    halifax
    Your Mercedes:
    merc C240, 2001,2.6L
    Thanks Sam-Unit and Supercharged for your help, finaly i just bought a new Sam wich cost about £250 + £40 to reprogram the chip because after fitting it myself the fuel gauge did not work, I tried to order a chip from Codecard, I payed using paypal, no one collected the money for nearly 2weeks then I panic and requested my money back and decided to run to dealer. Everythings working fine now.

    Anyway I just want to say thanks and stay blessed.
     

Share This Page