SL 500 MAF(?) problem.

xtriple

Senior Member
Joined
Feb 15, 2011
Messages
138
Reaction score
9
Location
Torquay Devon
Your Mercedes
208 Convertible 320. Vauxhall Astra estate (yuck!) Jeep Cherokee 4.0.
Yes, I'm back again! I only ever seem to post when I have a problem, which is very rude of me, but guess what, I have a problem!

Ever since I've had the car it's had a hesitation if you press the throttle hard from tickover, .5 of a second and its gone so no great problem andnot noticable when driving. However, it's started to get worse and it will hesitate (very slightly) if you accelerate from a standstill.

So, in my infinite (!) wisdom, I decided it had acquired an air leak so had a look today. Sure enough, there was a couple of dodgy vaccum pipe connections so I replaced those, but then noticed that by the air intake, there's a round five pin plug disconnected. Now, I have never touched that before so I plugged it in and screwed it up tight. Started the engine and it "hunts" at tickover like you wouldn't believe. However, the hesitation was gone.

Disconnected the plug again and all is back to normal: smooth reliable tickover.... and a hesitation!

So is this the MAF? If so, how the hell do you get the thing out? I had a look round the sides and can see no screws (not that you'd be able to get to them if there were!) and can only assume (yes, I know) that the complete round cylinder it's attached to has to come out - HOW!?

Sorry for the rambling post (all of mine are:( ) and I promise to TRY and be more of a team player in future.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Sounds like a purge valve fault more than the MAF
 
OP
xtriple

xtriple

Senior Member
Joined
Feb 15, 2011
Messages
138
Reaction score
9
Location
Torquay Devon
Your Mercedes
208 Convertible 320. Vauxhall Astra estate (yuck!) Jeep Cherokee 4.0.
  • Thread Starter
  • Thread starter
  • #3
Where is the purge valve? Would that cause the Maf to need disconnecting?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Was it the MAF that was disconnected, the purge valve sits on the nearside wheel arch on the inner wing wit a vacuum pipe going to it
 
OP
xtriple

xtriple

Senior Member
Joined
Feb 15, 2011
Messages
138
Reaction score
9
Location
Torquay Devon
Your Mercedes
208 Convertible 320. Vauxhall Astra estate (yuck!) Jeep Cherokee 4.0.
  • Thread Starter
  • Thread starter
  • #5
Yes. Apparently. Disconnected it runs fine apart from a hesitation, plugged in, it hunts at tickover and even comes close to stalling.

Oh, and good to see you're back, I missed you Malcolm.
 
Last edited:

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Nice to be back then yes the MAF has failed I think, the car will be more economical with a new one,,, try ECP for a good make and not Ebay, or ring your local Bosch service center
 

Avantgarde Automotive, Mercedes-Benz and SLR McLaren specialists. Service, repairs, diagnosis and motorsport preparation.
Unit 14 Hither Green Trading Estate, Clevedon, Somerset, BS21 6XU Tel: 01275 217270 Email:steve@avantgarde-automotive.co.uk
www.avantgarde-automotive.co.uk
Top Bottom