sl 55 cut out

greenholme

New Member
Joined
Sep 24, 2009
Messages
9
Reaction score
0
Location
nottingham
Your Mercedes
sl55 amg
can anybody shed some light on this one,while driving today i stopped to make a right turn and the engine just cut out i tried to start it but it wouldnt fire up the dash lights were on and all gauges worked when the start button was pressed i couldnt hear it turn over but the dash lights flickerd as if engine was turning over ,eventually it re started after a couple of mins on the key but the engine diognastics light stayed on when i got home i stopped engine and fired it up on start button with no probs but engine light still stayed on would appreciate anybodys thoughts on diagnosis so i canget it fixed thanks.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
We have another post running on a possible keyless go and the same fault. If it does it again please try the key in the ignition,,also please look at the rev counter when it does not start to see if the needle flicks up.

The engine lamp on is a rare fault on this, and I cannot think what this would be at this stage
 
OP
G

greenholme

New Member
Joined
Sep 24, 2009
Messages
9
Reaction score
0
Location
nottingham
Your Mercedes
sl55 amg
  • Thread Starter
  • Thread starter
  • #3
i looked in manual atthe engine light explanation it says probable causes to check ignition ,emmisions or exhaust maybe electrical fault with ignition as it just cut out ?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
i looked in manual atthe engine light explanation it says probable causes to check ignition ,emmisions or exhaust maybe electrical fault with ignition as it just cut out ?

Sorry then I am reading it all wrong,,if the engine just stop,,and re starts a little later then 90% of these faults are the CPS that can go open circuit when hot and be perfect when cold

Sorry about my first post :(
 
OP
G

greenholme

New Member
Joined
Sep 24, 2009
Messages
9
Reaction score
0
Location
nottingham
Your Mercedes
sl55 amg
  • Thread Starter
  • Thread starter
  • #5
sorry malcom im not very technical in my description the car had only been running about 5 mins when it happened ,would the cps need replacing and is this an easy fix?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
sorry malcom im not very technical in my description the car had only been running about 5 mins when it happened ,would the cps need replacing and is this an easy fix?

You have choices,,plug the car into STAR,,and this may tell you what went wrong,,STAR does not always find the CPS as being at fault but the reason for the lamp will be there, and one can work it out from there.

The CPS cost £47 from Bosch service centers, it is fitted at the rear of the engine on the bell housing over the starter motor and 5 in this link

http://www.detali.ru/cat/oem_mb2.as...GA=722.643&CT=M&cat=07F&SID=15&SGR=075&SGN=04

When faulty they go open circuit but measure about 1k ohm when good
 
OP
G

greenholme

New Member
Joined
Sep 24, 2009
Messages
9
Reaction score
0
Location
nottingham
Your Mercedes
sl55 amg
  • Thread Starter
  • Thread starter
  • #7
now that i have an idea of possiable fault will go an get it plugged in thank you very much for your info
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
now that i have an idea of possiable fault will go an get it plugged in thank you very much for your info

An indie is far cheaper than MB but ask first and they may match the price,,when you have the answer the techies here will soon put you straight as with what to do
 
OP
G

greenholme

New Member
Joined
Sep 24, 2009
Messages
9
Reaction score
0
Location
nottingham
Your Mercedes
sl55 amg
  • Thread Starter
  • Thread starter
  • #9
i use a good indie so will get him to check it out and let you guys know the score is afterwards thanks again
 
OP
G

greenholme

New Member
Joined
Sep 24, 2009
Messages
9
Reaction score
0
Location
nottingham
Your Mercedes
sl55 amg
  • Thread Starter
  • Thread starter
  • #10
just fired it up and engine diagnostic light has gone everything seems ok will still get it checked and let you know outcome thanks again for all your help
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
That engine lamp was a mystery, but at least the fault code will be in the memory
 
Top Bottom