SL55 AMG - Pulse Seats

olimango

Member
Joined
Apr 22, 2009
Messages
17
Reaction score
0
Hi

I'm a new member, so please bear with me on this one :)

I collected a 2003 reg'd SL55 over the weekend and wonder whether the pulse seats are working or not. The red light glows when I press it (on both driver and passenger seats) but am not sure whether it's blatenly obvious when the seat is 'in action'. Also there are a number of buttons around the PULSE button, but am not sure whether they are working or not.

When I press them I can hear a 'clicking' as thought something should be happening, but can't tell.

Does anyone think they might be able to help

Look forward to hearing from you.

Olimango
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hello and welcome, I have been where you are today.

First there are mods to the pipes under the seat as either the passenger or drivers seat can kink, blocking the air flow, the easy test is to try the other seat, as both seats do not fail together.

Mine did not work when I bought the car so I asked MB to check on STAR, they said leak on drivers seat,or the PSE pump was u/s, so I took the car home and took the seat apart, thats all of the leather off. made up my own device to blow the seat up and it stayed up all week.

Back to MB and I asked if I could go into the workshop, they let me in and I asked him to see if the car knew that it had comfort seats, he did not want to go there and look, but he did and they were not turned on, that was 2½ years ago and I have enjoyed them ever since, and they are one of the nicest extras on the car
 

mikestrivens

Senior Member
Joined
Nov 21, 2008
Messages
2,715
Reaction score
146
Location
Stockport
Your Mercedes
1995 W124 320TE, 1998 R129 SL500, 2016 Triumph Tiger 800 XCx
Welcome to the forum. There is a goldmine of info on this site. I've just realised this is my 100th post. Got a fair way to go before I have as many as Malcolm.
 
Last edited:

100%Bitch

Senior Member
Joined
Nov 9, 2006
Messages
3,783
Reaction score
51
Location
Norfolk 'n' good
Your Mercedes
216 Facelift CL500, 172 SLK55, Fiat Panda, Nissan Cube, R170 SLK230 & an Auto Trail Comanche.
You will know if your massage is working or not as the airbags in the seat will inflate by fiffering amounts and literally give you a slow massage.
 
OP
O

olimango

Member
Joined
Apr 22, 2009
Messages
17
Reaction score
0
  • Thread Starter
  • Thread starter
  • #6
Thanks for the welcome all - and for the advice. I'll take a look and come back to you as soon as things are sorted.

Oli
 

gerryfh

Active Member
Joined
Mar 18, 2010
Messages
29
Reaction score
0
Pulse Seats Not Working

Help any one got any ideas the pulse seats on my SL55 are not working, both seats don't work, red led comes on for a few moments on both seats but no movement, you cannot adjust either seat, when I operate the switches I can hear a clicking noise, but nothing else.

I've checked the cars fuses under the bonnet, and every thing fine there, suspension goes up and down too, are there any more fuses, is there a seperate pump if so does any one know where it is
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Help any one got any ideas the pulse seats on my SL55 are not working, both seats don't work, red led comes on for a few moments on both seats but no movement, you cannot adjust either seat, when I operate the switches I can hear a clicking noise, but nothing else.

I've checked the cars fuses under the bonnet, and every thing fine there, suspension goes up and down too, are there any more fuses, is there a seperate pump if so does any one know where it is

You just need to plug the car into STAR go to interior, then seats, then check that the comfort seats are activated.

It is possible that a vacuum pipe has split,,and one can deal with that later, but at the moment I do not think that they are turned on
 

gerryfh

Active Member
Joined
Mar 18, 2010
Messages
29
Reaction score
0
Thanks for that, but they used to work fine although the drivers seat was never brilliant, I've not used the car much in the last 6/7 months and the battery has been flat I've changed the engine bay battery and charged the rear I don't know if this has anything to do with it, is it possible do you think for the seats to turn themselves off as you suggest, the memory easy entry on the seat has only worked now and again.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Then they have turned themselves off,, and this could be due to a leak in one of the bladders or a pipe.

The PSE pump in the boot can only rune for 18sec max, in the event of a leak,, the SAM will turn the seats off to protect the pump.

Have it activated again, then blow up the bladders one by one and they should stay inflated for many days,, do check the vacuum pipes to see if they are kinked or cracked by raising the seat to max,,you can just see them
 

gerryfh

Active Member
Joined
Mar 18, 2010
Messages
29
Reaction score
0
Thanks very much for the advise I'll book the car in next week and get the pump switched on, I'll let you know how I get on, its got to go in anyway as the soft clossing boot lock has packed in
 

100%Bitch

Senior Member
Joined
Nov 9, 2006
Messages
3,783
Reaction score
51
Location
Norfolk 'n' good
Your Mercedes
216 Facelift CL500, 172 SLK55, Fiat Panda, Nissan Cube, R170 SLK230 & an Auto Trail Comanche.
Sounds to me that it's the pump at fault then.
 

Mic

Senior Member
Joined
Nov 12, 2009
Messages
4,271
Reaction score
128
Age
72
Location
Oxfordshire
Website
www.bennettgibbons.co.uk
Your Mercedes
MB SL500(2003), MB SLK320(2001), Volvo V70 XC AWD(2001)
Hello and welcome.

Well worth getting the Comfort seats fixed....the massage function is very welcome on a long drive.

Mic
 

gerryfh

Active Member
Joined
Mar 18, 2010
Messages
29
Reaction score
0
Thanks Mic, I'm one of these folks that likes everything to work, which is a bit of a pain with this SL55 as so much has gone wrong with it over the 4 years ive owned it, super charger, inter cooler, various water leaks, disks, steering rack !!!!! its lucky I love the car so can forgive it, I wouldn't mind but its only done 38k bought it at 7k when it was a year old :(
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Sounds to me that it's the pump at fault then.

The pump is fine,, all outlets are called up on the CAN,, if any circuit operates the pump for too long,,it shuts that outlet down.

I know that the pump has turned itself off as I have had the same thing,,you push the massage button it stays alight for a few seconds and goes out
 

Mic

Senior Member
Joined
Nov 12, 2009
Messages
4,271
Reaction score
128
Age
72
Location
Oxfordshire
Website
www.bennettgibbons.co.uk
Your Mercedes
MB SL500(2003), MB SLK320(2001), Volvo V70 XC AWD(2001)
Thanks Mic, I'm one of these folks that likes everything to work, which is a bit of a pain with this SL55 as so much has gone wrong with it over the 4 years ive owned it, super charger, inter cooler, various water leaks, disks, steering rack !!!!! its lucky I love the car so can forgive it, I wouldn't mind but its only done 38k bought it at 7k when it was a year old :(

Ouch

Mic
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded

I say that with my car too,,,just been investigating my can faults,, and I find that everything wakes up OK,, but there is a fluctuating voltage of between 1 and 10 volts on the CAN.

I can only work outside,,this make scoping very hard in the sun, so easier with a simple volt meter. I cannot do more right now as the car is needed this month, and the next stage could be all the seats and trim coming out,,but there is always something to do on a 230
 

gerryfh

Active Member
Joined
Mar 18, 2010
Messages
29
Reaction score
0
Well I was fortunate with all my faults MB did them all under warranty, the super charger was an interesting one though I took the car in and told them that the car ran out of steam at 140mph !!!!! up till that speed you couldn't tell the difference, in fairness they diagnosed it straight away.

The only pain was when I had it back they must have down loaded updated software into the vehicle as my speed limiter was set back at 155 !!!! cost me another few pounds to get it removed.
 


The SL SHOP YOUR ONE STOP SHOP FOR ALL THINGS SL, SERVICE & RESTORE, SALES, HIRE & PARTS
Choose from a wide range of superbly prepared SL’s each with a 12 month guarantee. We can service, update, re-trim, restore and repaint your 107 SL.
Choose from a 6 or 8 cylinder car for the day, the weekend, a month or a year. Contact us for a wide range of parts. Tel: 0844 414 2116 or visit our website atwww.theSLshop.com
Top Bottom