Star diagnostics will not communicate with gearbox ECU

Bybuys

Active Member
Joined
Feb 1, 2009
Messages
44
Reaction score
7
Location
Denton, Northants
Hi Guys
I have recently had problems with oil in the engine and gearbox loom and up to the ECUs on a 2001 230 CLK. I have had the offending components replaced and the loom extention fitted. I have thoroughyly washed out the ECUs and have since checked and cleaned out residue oil that made its way to the ECUs. For last 3 weeks no more oil whatsoever has appeared at the ECUs; they are perfectly clean. The problem of it going into limp-home mode has improved but it does still happen and, if I accelerate hard, it goes into neutral even though I am still in drive. Took it to an Indy who has put it on the Star diagnostics. It connected with the engine ECU no probs but it cannot communicate with the gearbox ECU and currently he cannot reset/reprogramme it. Is this likely to be an ECU failure causing this or could it be something else? I didn't have the looms changed so residue may exist in the wiring but it is definitely not at, or in the ECU currently.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
On the gearbox ECU plug, the two end connections are for the CAN BUS, it is a known fault that these can make a poor connection, and STAR finds the ECU via the CAN signal
 
OP
B

Bybuys

Active Member
Joined
Feb 1, 2009
Messages
44
Reaction score
7
Location
Denton, Northants
  • Thread Starter
  • Thread starter
  • #3
Thanks Television. What can i do to remedy this and can you be more precise as to which are the CAN BUS connectors
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I would measure the resistance over the CAN wires, On the end of the plug, there are two connections at one end on their own, one on 1 row and the other on the other row, I think that these are the only connections that have a gap from the rest. Get some non drying switch cleaner from Maplins and spray both the plug and socket well

I maybe able to do a print out for you but time is limited at the moment.

How was the ECU cleaned out
 
OP
B

Bybuys

Active Member
Joined
Feb 1, 2009
Messages
44
Reaction score
7
Location
Denton, Northants
  • Thread Starter
  • Thread starter
  • #5
I carefully opened it up but there was no sign of oil inside whatsoeve so did not mess with it. I cleaned the connectors with an alcohol based switch cleaner.
 


As a member of ourMercedes Owners' club, you will enjoy numerous savings on an expanding range of services including, Insurance, Parts and Servicing, RAC Membership plus much more.MBOmembers can save around £200.00 a year. You can join from as little as £30.00 and start to enjoy these savings immediately. You receive our monthly magazine and free classified ads when you decide to trade up a model.
Top Bottom