1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Viano electrical fault..nightmare intermittent

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Jonny2englisg, Dec 19, 2012.

  1. Jonny2englisg

    Jonny2englisg New Registration

    Messages:
    1
    Likes Received:
    0
    Joined:
    Dec 19, 2012
    Location:
    Derbyshire
    Your Mercedes:
    Viano/2004/CDi 2.2diesel
    All, new bod to this but have an electrical fault that is intermittent and goes away for weeks then comes back with a vengeance...multiple times in a day and then nothing again for days or weeks.
    Before I start on the symptoms and error code it has been electrically check on a number of occasions...error of diesel water filter sensor..replaced twice still same problem;
    So to the symptoms...driving along round town engine either losses power or stops, up come error messages BREAK ASSIST, ELECTRICAL STABILITY PROGRAM, AND THE GLOW PLUG WARNING LIGHT...a quick turn of the key and it restarts while the car is still moving or a push of the accelerator! Further to this and post diesel water filter replacement (which has been the only fault showing when tested) additional error Messages as above plus alternator and battery malfunction and coolant warning. These happened when the car was at traffic lights idling for change of lights and took a couple of key turns to restart it!

    So anyone out there who has any idea..don't want to get screwed at merc dealership...
    Vehicle: Viano, 2004 cdi2.2

    Thanks
    Jon
     
  2. Roxie

    Roxie Active Senior Members

    Messages:
    808
    Likes Received:
    10
    Joined:
    Sep 20, 2011
    Location:
    Lincolnshire
    Your Mercedes:
    C Class 350CDI 2012
    It could be something like a faulty relay causing power supply problems. I would need to know more details to guess further.
    You could try swapping them around to see if the problem moves.
     
  3. Alex Crow

    Alex Crow Senior Member

    Messages:
    10,677
    Likes Received:
    34
    Joined:
    Jul 9, 2009
    Location:
    Super Suffolk
    Your Mercedes:
    W169, W124, w202, W203, KTM 250 EXC, VW T25 camper and a Polo in a pear tree
    To help us help you, can you tell us which ECUs have been fault code read?
    If only the engine management, then that will not really help you.
    You need to be able to communicate with all the modules (eg ESP) to fault find here.

    Beyond that, yes, could well be a relay or something similar...
     
  4. cefarcat

    cefarcat Active Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Jul 12, 2011
    Location:
    Wales
    Your Mercedes:
    SLK 320 2001 3199cc V6
    I was working on a Fiat Ducato van which had a the same sort of problems, cutting out, not starting etc and loads of fault codes, it turned out with all this rain, water had gotten into the fuse/relay box under the engine causing corrosion and some shorting. After taking it apart and cleaning and spraying everything except the contacts with electrical vanish problem solved, not saying this is your problem but might be worth checking out. Whilst researching the Fiat problem another common fault was bad earths in the engine bay especially the main engine earth
     
    Last edited: Dec 20, 2012

Share This Page