W124 320CE rear window not working

col320ce

Senior Member
Joined
Jun 23, 2009
Messages
212
Reaction score
12
Location
Australia
Your Mercedes
320CE Sportline
1993 W124 320CE
Rear right electric window not going up/down. All others work ok, fuses ok. I can hear a relay click when I press the window button but can't hear anything else (no motor noise).

I suspect the problem is between the relay and the window motor.

Any further ideas on this - where should I look first?
I can't remove the trim from infront of the rear window to get to the mechanism.
Has anyone got 68-456 notes on how to do this?

Thanks for any help
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
This could just be the motor stuck,,with a sticky carbon brush,
I can let you have the door trim removal instructions
 
OP
col320ce

col320ce

Senior Member
Joined
Jun 23, 2009
Messages
212
Reaction score
12
Location
Australia
Your Mercedes
320CE Sportline
  • Thread Starter
  • Thread starter
  • #3
Thanks, PM sent with my email address...
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Often just giving the motor a clout, will bring it back to life when a brush is stuck
 
OP
col320ce

col320ce

Senior Member
Joined
Jun 23, 2009
Messages
212
Reaction score
12
Location
Australia
Your Mercedes
320CE Sportline
  • Thread Starter
  • Thread starter
  • #5
Motor replacement

I have the panel off and can see the motor (driving a cable). When switching the window switch there is 12V going to the motor. I have moved the motor around a bit and can't get any life out of it.

Can the motor be replaced without messing around with the pully arrangement? I tried to separate the motor but is pretty tight so did not persist as I did not want to break anything ...

Thanks for any help ...
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I can give you the info,,have you tried whacking it
 
OP
col320ce

col320ce

Senior Member
Joined
Jun 23, 2009
Messages
212
Reaction score
12
Location
Australia
Your Mercedes
320CE Sportline
  • Thread Starter
  • Thread starter
  • #8
I've tried whacking it. If you could send the info that would be great. I assume you still have my email?

Will post a picture to - tomorrow.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
What did I send you before so that I can find the address
 
OP
col320ce

col320ce

Senior Member
Joined
Jun 23, 2009
Messages
212
Reaction score
12
Location
Australia
Your Mercedes
320CE Sportline
  • Thread Starter
  • Thread starter
  • #10
The door trim removal instructions - see the top of this thread. I can PM you again if required.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Details sent :D
 
OP
col320ce

col320ce

Senior Member
Joined
Jun 23, 2009
Messages
212
Reaction score
12
Location
Australia
Your Mercedes
320CE Sportline
  • Thread Starter
  • Thread starter
  • #12
Here is the motor

Looks like there is a problem getting 12v through to the bushes.

I suspect the box that is attached to the green cable is broken. I will need to remove it to work out what it is?? then replace it...

I think it should work after this.

1.jpg

2.jpg

3.jpg
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
The brushes do not look good,,plenty of life, looks as though it be arcing
 

Dec

Senior Member
Joined
Nov 30, 2005
Messages
3,300
Reaction score
4
Location
Ireland.
Your Mercedes
W202
Don’t replace anything until you have cleaned reassembled and tested.

Dec
 
OP
col320ce

col320ce

Senior Member
Joined
Jun 23, 2009
Messages
212
Reaction score
12
Location
Australia
Your Mercedes
320CE Sportline
  • Thread Starter
  • Thread starter
  • #16
Will clean and check. The black box looks like it is a thermal overload protection unit. If not working I will short it out and see if this gets it going.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Yes they do have one
 

Dec

Senior Member
Joined
Nov 30, 2005
Messages
3,300
Reaction score
4
Location
Ireland.
Your Mercedes
W202
Col. What state was the commutator in, thats the part that needs a matchstick and sandpaper to clean. If that box is a thermal overload protector it would reset itself after a short time.
When you clean and reassemble, run the motor on a bench, independently of the cars electrics by means of a battery charger.

Dec
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Col. What state was the commutator in, thats the part that needs a matchstick and sandpaper to clean. If that box is a thermal overload protector it would reset itself after a short time.
When you clean and reassemble, run the motor on a bench, independently of the cars electrics by means of a battery charger.

Dec

They should re set Dec but they can go faulty
 

Dec

Senior Member
Joined
Nov 30, 2005
Messages
3,300
Reaction score
4
Location
Ireland.
Your Mercedes
W202
Agree Malcolm just don’t like to see it being taken apart until he has tried cleaning and testing first.

Dec
 


Comand (Europe) Ltd are the leading specialists in supplying and fitting Comand, Linguatronic, Media interface kits, UHI phone, IPod interfaces and much more.
Top Bottom