W124 fault codes

5907

Senior Member
Joined
Feb 12, 2009
Messages
124
Reaction score
0
I checked the codes on my '95 E280 to see if there were any clues to the intermittent hunting idle and lack of top-end power, and got the following on pin 8:

13 O2S (Lambda) control system operating at rich or lean limit

35 Model 124,129 and 140 AIR pump switchover valve and/or electromagnetic AIR pump
clutch. Model 202 AIR pump switchover valve and/or AIR relay module


I can see what 13 means, but 35 doesn't mean anything to me.

I was hoping for code 4 to finally prove that the MAF is faulty, but code 4 didn't show up. Does this mean I need a new Lambda sensor?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Your codes all point in the same direction ---running too weak

It would appear that the lambda is at fault, the air pump when fitted further weaken the fuel mix when it gets too rich,

The MAF can cause the above symptoms by giving false info and making the mixture too weak
 
OP
5

5907

Senior Member
Joined
Feb 12, 2009
Messages
124
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
Your codes all point in the same direction ---running too weak

It would appear that the lambda is at fault, the air pump when fitted further weaken the fuel mix when it gets too rich,

The MAF can cause the above symptoms by giving false info and making the mixture too weak

Do you think maybe the Air pump isn't switching off properly, and making the mixture too lean?
 

kth286

Senior Member
Joined
Nov 4, 2002
Messages
3,067
Reaction score
2
Your Mercedes
E320 Coupe 95
They may of course be codes that have not been cleared from previous work.

I would always clear the codes and go for a drive and check again.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Do you think maybe the Air pump isn't switching off properly, and making the mixture too lean?

Very few cars have them in this country,do you have one
 
OP
5

5907

Senior Member
Joined
Feb 12, 2009
Messages
124
Reaction score
0
  • Thread Starter
  • Thread starter
  • #6
Very few cars have them in this country,do you have one

Not 100% sure; I think my last 300TE had one though, isn't it the Air pump that makes a racket for about 2 minutes after a cold start?
 

Peter Best Insurance is a leading specialist in Mercedes-Benz insurance. All MBO members are eligible for exclusive rates on all our classic car policies.
Call now for our 'BEST' quote. Tel: 01376 573033
Top Bottom