w202 losing power when driving

japimport

Senior Member
Joined
Feb 19, 2008
Messages
142
Reaction score
0
Location
The Emerald Isle
Your Mercedes
mercedes c200 sport,mercedes c200 elegance
hi ther everyone i have a c200 year 95 and 123,000 miles on the clock every now and again my car loses power when driving and when sometimes stoped at traffic lights the car would shake like crazy its like its going to cut out then id turn the car off and start it back up and it would be grand as if nothing happened ive noticed it only happens when the car is at running temperature ive already changed the fuel filter ignition coils cleaned the throttle body ive checked the ignition leads for sparks and its ok does anyone have any idea what it could be just so i can try and find the problem thanks very much
 

Alps

Senior Member
Joined
Aug 26, 2003
Messages
672
Reaction score
24
Location
london\Essex
Your Mercedes
SOLD - 2013 Weistec E63 AMG, 2004 E55 (x2)
sounds like the mass air sensor.
 
OP
japimport

japimport

Senior Member
Joined
Feb 19, 2008
Messages
142
Reaction score
0
Location
The Emerald Isle
Your Mercedes
mercedes c200 sport,mercedes c200 elegance
  • Thread Starter
  • Thread starter
  • #4
i havent got one of those on my car i have the one that goes in beside the throttle body
 

C220GJS

Senior Member
Joined
Feb 13, 2006
Messages
1,021
Reaction score
68
Age
71
Location
Shotts, Scotland.
Your Mercedes
1995 W202 C220 Elegance
As your car doesn't have a maff the obvious culprit would be the OVP relay, they give all sorts of problems and unless your's has been replaced already and it is a Seimens unit I would say replace it now,about £50+from ECP or GSF.
 
OP
japimport

japimport

Senior Member
Joined
Feb 19, 2008
Messages
142
Reaction score
0
Location
The Emerald Isle
Your Mercedes
mercedes c200 sport,mercedes c200 elegance
  • Thread Starter
  • Thread starter
  • #6
thanks for the reply do you where the ovp relay is in my car
 

C220GJS

Senior Member
Joined
Feb 13, 2006
Messages
1,021
Reaction score
68
Age
71
Location
Shotts, Scotland.
Your Mercedes
1995 W202 C220 Elegance
Under the ECU cover at the back nearside of the engine bay, it's a silver relay with a fuse on top. Wrong side Dec.
 
OP
japimport

japimport

Senior Member
Joined
Feb 19, 2008
Messages
142
Reaction score
0
Location
The Emerald Isle
Your Mercedes
mercedes c200 sport,mercedes c200 elegance
  • Thread Starter
  • Thread starter
  • #10
thanks alot guys eill let yous know how i get on
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Does the car have an OVP relay,its a 1995 car, if the car is motronic then the OVP relay can affect the idle only, though if really bad thew ABS lamp would be lit
 

D3AN

Senior Member
Joined
May 3, 2007
Messages
67
Reaction score
0
Location
West Midlands
Your Mercedes
Mercedes C180 Esprit
Not wanting to go off the subject, but can the OVP Relay cause poor idling? If so how does this work? should I start a new thread for this? Thanks
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Not wanting to go off the subject, but can the OVP Relay cause poor idling? If so how does this work? should I start a new thread for this? Thanks

With some engine management systems the OVP relay is used to protect it. This is only after 1990 on some systems, one in question is the 124061.

On all MB's there are 2 parts to the engine control, the idle and driving, and the activity is different on both, each half must know what the other half is doing. pre 1990 the was idle relays, after this they are all in one
 
OP
japimport

japimport

Senior Member
Joined
Feb 19, 2008
Messages
142
Reaction score
0
Location
The Emerald Isle
Your Mercedes
mercedes c200 sport,mercedes c200 elegance
  • Thread Starter
  • Thread starter
  • #14
my abs light doesnt come on at all all though the car does have a slight shaking when idle it would shake then correct it self for a moment then it shakes again? im just clutching at straws at the moment
 
Last edited:

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
my abs light doesnt come on at all all though the car does have a slight shaking when idle it would shake then correct it self for a moment then it shakes again? im just clutching at straws at the moment

Your condition is known as hunting, something with an air supply possibly at fault.

Things do not get easier, we use digital meters now, and these are useless for finding this type of fault as they do not update fast enough, with the old meters with a needle,you could see the fluctuations
 


Over 100 branches Nationwide, More than 114,000 Parts in Stock, The UKs Largest, and Fastest Growing Parts Supplier,please see MBO Members’ Area for discount codeEuro Car Parts Ltd
Top Bottom