1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

w203 C320cdi 722.9 transmission problems

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by Jonathanc250, Nov 8, 2019.

  1. Jonathanc250

    Jonathanc250 Senior Member

    Messages:
    77
    Likes Received:
    1
    Joined:
    Sep 17, 2010
    Location:
    Leigh on Sea Essex
    Your Mercedes:
    2005 W203 C320 CDI
    Evening all,

    I've been having problems with the gearbox on my car for a while now, however I will start from the top and hopefully you'll be able to see where I'm at now.

    Originally the gearbox was playing up, loosing drive, limp mode etc..
    This was down to a faulty speed sensor on the conductor plate, which I removed and sent off to ecu testing to be repaired.
    Once I got the conductor plate back, I reinstalled it to the gearbox, with a new filter and fluid.
    I Cleared the codes and went for a drive, the gearbox was back to normal. (When I say normal, I mean it wasn't going into limp mode, or getting stuck in gear or loosing drive anymore)

    Then the turbo actuator decided to stop working, so I got another one of them and fitted it, now the car was driving pretty well, lots of power, still however the gearchanges were a bit off.

    From doing alot of reading, I found that the problems I was experiencing could be from not resetting the gearbox and then doing an adaptation, after getting the conductor plate repaired.
    So I used my diagnostic computer, a Delphi Ds150e I think it is, and proceeded to reset the transmission and torque converter adaptations. Then I tried to set the torque converter lock up adaptation.

    This is where the problems began , since doing this, the car now feels like its slipping the transmission quite a bit, and when driving steady at anywhere between 40 and 70, if the revs sit at around 12-1500 for a few seconds the car then starts bumping 3 or 4 times in quick succession, which I'm assuming is the torque converter trying to engage.
    I'm also getting a noise that sounds like turbo flutter, when the car slips and then changes gear, I'm not sure if this is the torque converter making this noise or not.

    Anyway, by trying to get rid of one problem, I've created another! From further reading, it appears there is a software update for the gearbox, that addresses the problems I was experiencing (Changing down to 1st while still moving slowly, harsh 1-2 and 2-3 shifts)

    Can anyone please help me get this sorted, I have the car booked in with Mercedes, but when I Said to them I would like the gearbox software updated and the torque converter lock up re-calibrated, I was initially told there is not an update available and the need to do a diagnosis first before they can say if there is an update, or re-calibrate anything @ £176 per hour!

    If anyone can shed any light or knows anyone who would be able to help in the Essex area I would really appreciate it

    Thanks in advance, and sorry for the long post!
     
  2. Larkone

    Larkone Senior Member

    Messages:
    262
    Likes Received:
    130
    Joined:
    Aug 19, 2016
    Location:
    NW Essex
    Your Mercedes:
    CLS 320CDI 2008
    See post on the other side re indy
     
    Jonathanc250 and Wighty like this.
  3. bembo449

    bembo449 Senior Member

    Messages:
    3,831
    Likes Received:
    1,107
    Joined:
    Jan 2, 2012
    Location:
    lincolnshire
    Your Mercedes:
    w221 320cdi , r170 23k , range rover vogue , insignia vxr , shitron dispatch
    find a decent indy in your area pal
     
    Wighty likes this.
  4. Wighty

    Wighty Senior Member

    Messages:
    7,359
    Likes Received:
    4,440
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    Take a drive out to Stowmarket to see Alex Crow (MB Independent )
     
    Jonathanc250 likes this.
  5. OP
    Jonathanc250

    Jonathanc250 Senior Member

    Messages:
    77
    Likes Received:
    1
    Joined:
    Sep 17, 2010
    Location:
    Leigh on Sea Essex
    Your Mercedes:
    2005 W203 C320 CDI
    Thanks for the reply’s guys, I have actually used Alex in the past, he done the fluid and filter change on my old 202 C250 and got a couple of broken glow plugs out too. I did call him last week I think it was, and unfortunately he told me it’s stealer only! The phone line was terrible though and I couldn’t hear what he was saying exactly, but I got the part where he said it was dealer only!
     
    Wighty likes this.
  6. OP
    Jonathanc250

    Jonathanc250 Senior Member

    Messages:
    77
    Likes Received:
    1
    Joined:
    Sep 17, 2010
    Location:
    Leigh on Sea Essex
    Your Mercedes:
    2005 W203 C320 CDI
    Does anyone happen to know if this software update actually exists for the early 722.9 gearboxes, and if you have had it done to your car, did it make a difference ?
     

Share This Page