1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

W203 Electrics go off when i start engine

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by paulbooton, Nov 30, 2012.

  1. paulbooton

    paulbooton New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Nov 30, 2012
    Location:
    UK
    Your Mercedes:
    C270/2002/2.7cdi
    Hi all

    Any advice on this probelm would be great.

    I went to start my W203 C270cdi this morning. It had been a freezing night and there was quite a heavy frost on the car.

    Car started ok but most electrics wouldn't operate (heater, rear window heater, windows, heated seats, speedo, fuel guage, rev counter, indicators, maybe more). The radio and lights were working not full beam though.

    I turned engine off and tried again. Same problem.

    I then turned engine off and tried electrics without starting engine. All the electircs then worked perfectly. No problems. Heater, heated seats, indicators etc all worked without problem.

    Started engine again. All electircs went off and i proceeded to drive to work freezing.

    Cant work it out. I have tried taking battery off for a while and reconnecting but no luck.

    Any help would be appreciated:confused:
     
  2. Dec

    Dec Senior Member

    Messages:
    3,300
    Likes Received:
    3
    Joined:
    Nov 30, 2005
    Location:
    Ireland.
    Your Mercedes:
    W202
    How old is the car and how old is the car battery?

    Dec
     
  3. OP
    paulbooton

    paulbooton New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Nov 30, 2012
    Location:
    UK
    Your Mercedes:
    C270/2002/2.7cdi
    Car is 2003.

    Battery is about 2 years old.
     
  4. Dec

    Dec Senior Member

    Messages:
    3,300
    Likes Received:
    3
    Joined:
    Nov 30, 2005
    Location:
    Ireland.
    Your Mercedes:
    W202
    It sounds like the battery is in poor condition, are you doing infrequent and/or short trips?
    Convenience feature, the consumers you describe above, can become unavailable if there is insufficient voltage in the battery and become available again when the battery voltage recovers after starting, are you getting any warning signs on the dash display?

    Dec
     
  5. OP
    paulbooton

    paulbooton New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Nov 30, 2012
    Location:
    UK
    Your Mercedes:
    C270/2002/2.7cdi
    Battery is in good condition.

    I started again and this time it all worked. Went to garage to fill it up.

    Stopped it and started again and heard a small clicking for a couple of seconds after the car started up. Again the problems were there.

    Stopped it and started again. Didnt hear the clicking for a few seconds this time and all the electrics were working.

    Seems like the clicking I hear after starting is causing the electrics symptoms.
     
  6. Dec

    Dec Senior Member

    Messages:
    3,300
    Likes Received:
    3
    Joined:
    Nov 30, 2005
    Location:
    Ireland.
    Your Mercedes:
    W202
    No idea I’m afraid other than to suggest you have someone start the car while you try to identify the location of the clicking when the bonnet is open, others may know more.

    Dec
     
    Last edited: Nov 30, 2012
  7. WG M-B

    WG M-B Senior Member Authorised Forum Supporter

    Messages:
    3,105
    Likes Received:
    6
    Joined:
    Dec 5, 2010
    Location:
    North west london
    Your Mercedes:
    C63 Wagon in black
    I would imagine the clicking to be one of the flap motors behind the dash. Do you have a spare key you can try? Failing this I imagine your car has a problem between the eis and the front Sam unit/ possibly rear Sam unit as well. Car needs to go on star to be checked properly
     
  8. OP
    paulbooton

    paulbooton New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Nov 30, 2012
    Location:
    UK
    Your Mercedes:
    C270/2002/2.7cdi
    Think I'll try locating the clicking with someone Dec. No doubt it will work fine every time when I try though!

    Don't have a spare key WG. Looks like I'll need to get it on star then.
     

Share This Page