W204 OM642 V6 engine- shudder on switching off

Lord_Lucan

Senior Member
Joined
Sep 6, 2015
Messages
930
Reaction score
147
Location
Bedfordshire, UK
Your Mercedes
No longer own a Mercedes Benz
Hi All,

Noticed twice in the last week that my car (with the above engine) has shuddered when I switch it off and I was a little concerned. It drives fine and is always run up to temperature and on long runs so concerns about DPF etc but I'd like to know more about this if anyone else here has experienced similar.

Any ideas chaps?
 

alexanderfoti

MBO Forum Supporter
Authorised Forum Supporter
Joined
Mar 25, 2010
Messages
13,158
Reaction score
3,295
Location
Tonbridge
Your Mercedes
W221 S65 AMG - W204 C63 AMG + Various other MB's
Engine/gearbox mounts are probably past due.
 

KennyN

Senior Member
Joined
Dec 18, 2013
Messages
1,383
Reaction score
618
Location
Paisley
Your Mercedes
BMW 440i, Cayenne, ZX12r / ZRX11 / ZRX Monoshock
+1 for the mounts.

They are fluid filled and it may be worth a quick look under the car at the mounts and check for some seepage .

Check YouTube for ways to check them.

The ones for my CLS , inc G/Box mount, were £214 supplied from MB Grangemouth.

Kenny
 
OP
Lord_Lucan

Lord_Lucan

Senior Member
Joined
Sep 6, 2015
Messages
930
Reaction score
147
Location
Bedfordshire, UK
Your Mercedes
No longer own a Mercedes Benz
  • Thread Starter
  • Thread starter
  • #4
Thanks guys, that's just the sort of suggestion I was hoping for from the experts on the forum.

Will get it in the air over the weekend and take a good look around & report back. Cheers
 


Chris Knott Insurance, see oursticky posts here!
www.ckinsurance.co.uk
Top Bottom