1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

W210 engine shaking with low RPM

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by amkahal, Dec 29, 2012.

  1. amkahal

    amkahal Active Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 10, 2012
    Location:
    Lebanon
    Your Mercedes:
    E230 Avantgarde 1997
    Hi,
    I have a serious problem with my W210 E230 1997,
    only on cold days (when below 15C, i noticed), i start the engine a wait for at least 5 min to warm up, then when i switch the stick from P to D or R the engine shakes and the RPM goes to lower than 500rpm, then after 2 sec the RPM is stable,(on days with 5C or lower the engine goes off). this happens for the first time only, i mean when i switch back to P and again to D the problem disappear.

    Yesterday i found that when i switch from P to N, from N to R then to D, i bypass the problem, but that is not a solution.
     
  2. Robbostanhill

    Robbostanhill Senior Member

    Messages:
    602
    Likes Received:
    0
    Joined:
    Dec 22, 2011
    Location:
    Dartford, Kent, UK
    Your Mercedes:
    E270 Estate 2003 and *Her* C220 W203
    Sounds like auto transmission fluid too cold,
    Try changing the fluid and the filter (and gasket on sump)
     
  3. OP
    amkahal

    amkahal Active Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 10, 2012
    Location:
    Lebanon
    Your Mercedes:
    E230 Avantgarde 1997
    it sounds too strange for me, it's not an engine issue ??
     
  4. OP
    amkahal

    amkahal Active Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 10, 2012
    Location:
    Lebanon
    Your Mercedes:
    E230 Avantgarde 1997
    i found today, that,in the same situation, when i switch fast the stick from P to 4 , the problem had never appear, so any idea ??
     
  5. rapide

    rapide Senior Member

    Messages:
    639
    Likes Received:
    3
    Joined:
    Mar 9, 2008
    Location:
    west sussex
    Your Mercedes:
    1997 E230 (no rust) 2016 volvo xc60 r/design. se. lux. nav.
    shaky e230

    Hi i have the same car but its in tip top shape has yours been serviced properly it just might be struggling for revs due to bad plugs or air filter/ fuel filter blocked etc if the idle is to slow any way due to this it will falter when you select gears due to the drag in the gearbox its not a box fault the engine sounds down on power to me! as i have said has it been serviced recently and correctly!
     
  6. OP
    amkahal

    amkahal Active Member

    Messages:
    37
    Likes Received:
    0
    Joined:
    Dec 10, 2012
    Location:
    Lebanon
    Your Mercedes:
    E230 Avantgarde 1997
    Actually it is not serviced recently, but today i noticed that the stick is harsher than what it is in the summer, maybe this help to diagnostics the problem.
     
  7. rapide

    rapide Senior Member

    Messages:
    639
    Likes Received:
    3
    Joined:
    Mar 9, 2008
    Location:
    west sussex
    Your Mercedes:
    1997 E230 (no rust) 2016 volvo xc60 r/design. se. lux. nav.
    rough e210

    Hi again as i have said a harsh feel / shaking is normally an engine problem rough running etc make sure its tip top on service and running ok before moving on to other things! it should tick over at about 600rpm very smoothly in neutral or in any gear hot or cold if its a good engine . bad service or engine = bad tick over low power! harsh feel to car bad gear selection etc thats my guess! if it didnt change gear was stuck in gear it would be the box!
     
    Last edited: Jan 17, 2013

Share This Page