W220 transmission kickdown issue

SPG1952

Member
Joined
Sep 4, 2019
Messages
10
Reaction score
6
Your Mercedes
S320CDI 2001 diesel
Good afternoon all, I have a 2001 S320 cdi with 46000 miles on it and have an issue with the transmission. When 1st started car will accelerate smartly if required, however, soon thereafter kickdown becomes inoperable and acceleration sluggish and rev's unhappy to proceed past 2000 or so. Does anyone have thoughts and or had a similar experience? Thanks in advance for help/advice
 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
31,363
Reaction score
21,629
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240 (RIP), 02 R230 SL500, 04 Smart Roadster Coupe, 11 R350CDi
Sounds like the car is going into limp mode.
Probably needs putting on Star to see what's going on.
 
OP
S

SPG1952

Member
Joined
Sep 4, 2019
Messages
10
Reaction score
6
Your Mercedes
S320CDI 2001 diesel
  • Thread Starter
  • Thread starter
  • #3
Sounds like the car is going into limp mode.
Probably needs putting on Star to see what's going on.
Thanks, I concur.. have to see if my local indy guy is open whilst all world upside down!!
 

alexanderfoti

MBO Forum Supporter
Authorised Forum Supporter
Joined
Mar 25, 2010
Messages
15,163
Reaction score
6,342
Location
Tonbridge
Your Mercedes
W221 S65 AMG - W204 C63 AMG + Various other MB's
Based on how the symptoms come on, I would suspect EGR. Most other faults will cause limp mode from startup.
 
OP
S

SPG1952

Member
Joined
Sep 4, 2019
Messages
10
Reaction score
6
Your Mercedes
S320CDI 2001 diesel
  • Thread Starter
  • Thread starter
  • #5
Based on how the symptoms come on, I would suspect EGR. Most other faults will cause limp mode from startup.
Thanks Alexanderfoti the plot thickens methinks!! Will call the garage on Monday to see if anyone home... cheers all..
 


Chris Knott Insurance, see oursticky posts here!
www.ckinsurance.co.uk
Top Bottom