glow plugs

  1. W

    Brand new glow plugs, engine won’t start

    I just replaced all 5 glow plugs with Bosch glow plugs on my 2.5l turbo diesel and after putting everything back together my glow plug light won’t come on the dash, and the engine will not start. Any advice?
  2. B

    Glowplugs light on a few minutes after i start the engine

    Hello guys, I am new in that forum and I would like to apologize, if I don't ask something properly. I have an old Mercedes C220 CDI estate 2002 year. Today I noticed that when I started the engine up the glow plugs light remained on for probably a minute and then it went off. As far as I am...
  3. K

    [Wanted] glow plug wiring loom for Mercedes Elegance TD Auto 1997

    Hi I'm looking for a glowplug wiring loom for my Mercedes Elegance TD Auto 1997 Estate, 2497 CC VIN WDB2021882F61467G Engine Number 60596022016569 R573 JNL. Mercedes officially don't have the part and I've tried the regular car brakers websites. The car otherwise runs very well, so would...
  4. T

    W245 B180 CDI Glow plugs anomaly

    After cleaning EGR something happened with the glow plugs, as before everything was fine. Now glow plugs don't work, as in the morning when it's feezing outside, it takes a while for the engine to start. After starting, the glow plugs light on dash stays on for the whole ride, although few times...
  5. P

    Replacing glow plugs

    Having been told I have three defective glow plugs on my recently-acquired CLK320CDI, I have had a look around the forum to see if this is a reasonable DIY job for someone who has done a lot of minor maintenance work on his old 300CE for many years. And I seem to come across conflicting...
  6. P

    CLK 270 Cdi W209 2003 siezed glowplugs & EML on full throttle

    Hi Guys, First off, I'm a first time Merc owner having only purchased the car at the start of February and I seem to have had nothing but niggles and issues since. The car: CLK 270 CDI auto, 2003 model on 52 plate. I live in the north east and traveled down to Peterborough to collect the...
  7. H

    E320 Estate (2007) slow to start...

    Ok Guys looking for advice: When starting the car (it a CDI) I switch the key and wait for the glow plug indication to go out. Then turn and starter motor goes but car does not fire. Stop starter motor and repeat - car starts first time. Have had (twice) the glow plug indicator remain on...
  8. zedmeister

    CLS glow plugs - nightmare!

    Hi, Just gave my CLS in for servicing at an indie - the glow plug light used to stay on for about 1 min after starting so he said I needed to change the plugs - he said best to change all 6. Well, he changed 3 and broke the other 3. What should I do? Any diesel specialists nearby or someone...
  9. C

    Glow Plugs

    Morning everyone, I'm looking for a bit of advise regarding my 03 C220 cdi. I began to have some starting problems last year during the cold weather ending up with being taken to a garage and a heater being put under it for 4 hours before they could get it going! Have had the same...
  10. J

    W202 ECU Light on starting

    I have a 1998 W202 2.2D non-turbo estate auto with 185,000 miles. On starting normally on the glow plugs, the ecu light remains on and after a few moments the engine becomes lumpy and the transmission is in limp mode. However, if you start it on the glow plugs normally, let it run for few...
  11. E

    Lumpy E300TD, changed glow plugs ... now what?

    Having started perfectly through all the sub-zero weather, my '98 w210 E300TD, 112k, started displaying the glow plug warning after starting, running on less than all cyclinders for a minute or so and producing a white cloud of smoke on start up. After a couple of minutes (and before reaching...
  12. J

    Sprinter 311 CDI Cold Starting Problems

    Having problems starting my 2004 2.2 CDI Sprinter on cold mornings even after replacing all the glow plugs and the relay. The glow plug warning light is still staying on for around a minute after starting. A test shows that there is power to the plugs so I am at a loss as to what the problem...
Top Bottom