124 electrics

JACKLEE

Active Member
Joined
Feb 25, 2009
Messages
28
Reaction score
0
Location
hoddesdon herts
Your Mercedes
260 e saab 900 HONDA ACCORD
any help on instrument lighting heating controls electic window switches etc main lights on
 

roadhog

Senior Member
Joined
Aug 2, 2007
Messages
1,616
Reaction score
2
Location
Sunny Norfolk
Your Mercedes
W124 300D x2, C124 300
What sort of help? If your instrument lights are dim/off with the lights switched on try turning the trip reset as that's where you adjust the brightness. Took me a while to find out as well.

PS: Hello and welcome. :)
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Hello and welcome, as roadhog, turn the speedo re set knob a few times sharply
 
OP
J

JACKLEE

Active Member
Joined
Feb 25, 2009
Messages
28
Reaction score
0
Location
hoddesdon herts
Your Mercedes
260 e saab 900 HONDA ACCORD
  • Thread Starter
  • Thread starter
  • #4
instrument lighting

HI HAVE TRIED DIMMER SWITCH SEVERAL TIMES CHECKED BULBS REMOVED SPEEDO CLEANED CONTROLS STILL NO JOY EVERY THING ELSE WORKING FINE APART FROM HEATED REAR WINDOW SWITCH WILL WORK SOMETIMES:confused: ANY HELP WILL BE APPRECIATED JACKLEE
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
So you have the instrument lights back now all working, and the only fault now that was not mentioned before is that the heated rear window switch does not work sometimes, or is it the back lighting that is not working sometimes
 
OP
J

JACKLEE

Active Member
Joined
Feb 25, 2009
Messages
28
Reaction score
0
Location
hoddesdon herts
Your Mercedes
260 e saab 900 HONDA ACCORD
  • Thread Starter
  • Thread starter
  • #6
so you have the instrument lights back now all working, and the only fault now that was not mentioned before is that the heated rear window switch does not work sometimes, or is it the back lighting that is not working sometimes

hi no lights are working only speedo lights have tried dimmer switch still no lights mentioned heated rear window switch thought it might have been on same supply many thanks
 
OP
J

JACKLEE

Active Member
Joined
Feb 25, 2009
Messages
28
Reaction score
0
Location
hoddesdon herts
Your Mercedes
260 e saab 900 HONDA ACCORD
  • Thread Starter
  • Thread starter
  • #7
Hi no lights working after several attempts at dimmer swich have checked all bulbs replaced with new still no lights on heater controls electric window swithes (all) etc
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
The only thing that I know then is to check the tiny red fuse on the rear of the cluster, rated at 1 amp
 
OP
J

JACKLEE

Active Member
Joined
Feb 25, 2009
Messages
28
Reaction score
0
Location
hoddesdon herts
Your Mercedes
260 e saab 900 HONDA ACCORD
  • Thread Starter
  • Thread starter
  • #9
jacklee

Many thanks will try can you tell me where to look many thanks
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
You have to pull or push the cluster out, and it is on the rear
 
OP
J

JACKLEE

Active Member
Joined
Feb 25, 2009
Messages
28
Reaction score
0
Location
hoddesdon herts
Your Mercedes
260 e saab 900 HONDA ACCORD
  • Thread Starter
  • Thread starter
  • #13
jacklee

HI MANY THANKS FOR REPLY BUT I CAN NOT FIND FUSE ANYWHERE ANY PICTURES PLEASE :confused:
 

The Crooner

Active Senior Members
Joined
Sep 24, 2008
Messages
665
Reaction score
62
Location
Woodhall Spa Lincolnshire
Your Mercedes
2006 R320 cdi
You cabt see it until you have pulled out the cluster.

Its on the rear of the cluster, on the left hand side as you look at the front of the car.

You need to loosen the speedo cable, then remove it, and another large connector from the rear of the cluster.

I did it - cant be difficult then.

Tony
 
OP
J

JACKLEE

Active Member
Joined
Feb 25, 2009
Messages
28
Reaction score
0
Location
hoddesdon herts
Your Mercedes
260 e saab 900 HONDA ACCORD
  • Thread Starter
  • Thread starter
  • #16
Jacklee

Sorry but cannot find pictures
 
OP
J

JACKLEE

Active Member
Joined
Feb 25, 2009
Messages
28
Reaction score
0
Location
hoddesdon herts
Your Mercedes
260 e saab 900 HONDA ACCORD
  • Thread Starter
  • Thread starter
  • #18
Jacklee

Many thanks mine is blue that i take it is the wrong one ( has a bulb) i wil purchase one from mercs and try that will inform you of results once again thank you very much paul
 
OP
J

JACKLEE

Active Member
Joined
Feb 25, 2009
Messages
28
Reaction score
0
Location
hoddesdon herts
Your Mercedes
260 e saab 900 HONDA ACCORD
  • Thread Starter
  • Thread starter
  • #19
jacklee

Hi malcolm fuse done the trick thankyou if you dont mind i have one more problem have no remote locking on car open by key the problem is that it only opens the drivers door all others have to be opened manually any advise please ps i can see movement passenger door rear left hand when key is in locked position thanks paul
 


Chris Knott Insurance, see oursticky posts here!
www.ckinsurance.co.uk
Top Bottom