1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

270 cdi morning problem

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by Whizz, Nov 21, 2019.

  1. Whizz

    Whizz New Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Feb 4, 2019
    Your Mercedes:
    C class CDI 2.7 53 plate
    Hi the car starts first time every time but often sounds like a tractor. when i drive 500 yards and stop at the lights when i pull away it revs up . it only does this once a day !. if i dont stop its 80 out of 100 times its ok. the engine seems to tak a while to heat up. cabin heater isnt as hot as it was either.
    had oil changed, diff oil changed and steering fuild changed at last service 600 miles ago.

    Any ideas ?
     
  2. Dean Fletcher

    Dean Fletcher Senior Member

    Messages:
    2,588
    Likes Received:
    1,552
    Joined:
    Mar 24, 2018
    Location:
    Penrith, Cumbria
    Your Mercedes:
    Mercedes E250 coupe
    Hi and welcome Whizz. Possibly the thermostat? Have you had any coolant level issues?
     
  3. mioba

    mioba Senior Member

    Messages:
    1,884
    Likes Received:
    556
    Joined:
    Feb 19, 2006
    Location:
    Nottingham
    Your Mercedes:
    W124/E200, W220/S320CDI, W205/C200, W251/R350CDI 4Matic
    Agree with the stat (merc stats are not the best), whats the temp reading on the dash, should get upto temp after about 18 mins on a diesel in this colder weather
     
  4. Dean Fletcher

    Dean Fletcher Senior Member

    Messages:
    2,588
    Likes Received:
    1,552
    Joined:
    Mar 24, 2018
    Location:
    Penrith, Cumbria
    Your Mercedes:
    Mercedes E250 coupe
    My E250 take between 10 and 15 minutes to up there
     
  5. mioba

    mioba Senior Member

    Messages:
    1,884
    Likes Received:
    556
    Joined:
    Feb 19, 2006
    Location:
    Nottingham
    Your Mercedes:
    W124/E200, W220/S320CDI, W205/C200, W251/R350CDI 4Matic
    sorry typo from me. I meant 8 mins
     
  6. Rory

    Rory Senior Member

    Messages:
    4,872
    Likes Received:
    164
    Joined:
    Feb 8, 2005
    Location:
    Cheshire, UK
    Your Mercedes:
    2005 C270CDi Avantgarde Estate
    20/25 mins in mine, that's gentle rolling A road driving, or stop start into town if I go the opposite direction. Had it from nearly new, always been the same. Wife has a new VW Tiguan diesel - water temp gauge shows 90C after a few mins, but flip the display to oil temp and it's still blank. Again, a good 20 mins to get the oil to 90C.

    I do get warm air pretty quick in my C270 - have the electric booster heater set to auto so it comes on if the outside temp is 8C or lower. Have to be moving for it to work.


    Don't understand the first part of the OPs post - does it mean the engine revs but the car doesn't move?
     
  7. joderest

    joderest Senior Member

    Messages:
    799
    Likes Received:
    472
    Joined:
    Apr 16, 2018
    Your Mercedes:
    ML270 2003
    i must admit, i cannot work out whats happening either.
    Perhaps he could explain the fault a bit more.
     
  8. Wighty

    Wighty Senior Member

    Messages:
    9,980
    Likes Received:
    7,038
    Joined:
    Aug 4, 2016
    Location:
    Sunny Essex
    Your Mercedes:
    W211/E320cdi/2009 and CLK200k 2009
    Have you had the fault codes read ?
     
  9. Taffy7hfa

    Taffy7hfa Senior Member

    Messages:
    1,134
    Likes Received:
    460
    Joined:
    May 29, 2016
    Location:
    Oxford
    Your Mercedes:
    2004 ML350 Inspiration .2002 ML270 CDI .2016 Hyundai i30 1.6crdi.2014 Peugeot 308 1.6 HDI.
    Confusing description of the problem , maybe the box is flaring between gears ?
     

Share This Page