1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bob Fair

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by BOBFAIR, Mar 9, 2010.

  1. BOBFAIR

    BOBFAIR Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Dec 23, 2009
    Location:
    New Zealand
    Your Mercedes:
    C250D
    :DHi, My name is Bob Fair and i own and run a one man Garage/Service Station in rural New Zealand. I am the proud owner of a Mercedes Benz C250D. I really love this car, but have a few annoying faults that i hope someone can help me with. The first fault is that sometimes when reversing it feels like the rear brakes are being applied and you have to really increase the revs to keep reversing. The next fault is that sometimes the indicators,hazard lights and the intermitent wiper all stop working, then after a while start they all start working again. I hope that someone out there can help with my problems. Regards Bob. PS If anyone is looking for a good buisness to buy please get in touch as i am ready for retirement.
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    289
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Hello bob and welcome,, the fault with the indicators, wiper etc will be in the N10 multifunction relay in the front fuse /control box, either dirty fuses making poor connections or dry soldered joints in the N10 its self.
     
  3. Steve@Avantgarde

    Steve@Avantgarde Forum Supporter Authorised Forum Supporter

    Messages:
    6,819
    Likes Received:
    984
    Joined:
    Dec 8, 2009
    Location:
    Bristol/Somerset
    Your Mercedes:
    C220CDI AMG Line Premium, SLR McLaren Roadster, SL55 & C32AMG
    Bob

    Have you checked the rear parking brake shoes arent siezed/broken up?

    Malcs reply is more likely the grief with your indicators!
     
  4. OP
    BOBFAIR

    BOBFAIR Member

    Messages:
    10
    Likes Received:
    0
    Joined:
    Dec 23, 2009
    Location:
    New Zealand
    Your Mercedes:
    C250D
    Hi, My 1994 C250D has'nt got a N10 malfunction relay. The relay box(Drivers side behind the fuse box) lettering only goes up to K. Regards Bob
     
  5. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    289
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    You have got one, the N10 is the term used by MB for referenced
     
  6. Dec

    Dec Senior Member

    Messages:
    3,300
    Likes Received:
    3
    Joined:
    Nov 30, 2005
    Location:
    Ireland.
    Your Mercedes:
    W202
  7. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    289
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Thank you dec,, I typed it all out did the preview but forgot to push the post button,,it must be an age thing:rolleyes:
     

Share This Page