c250 d auto

kirkbylads

New Member
Joined
Jul 17, 2009
Messages
3
Reaction score
0
hi there newby here.
i have just bought a 1994 c250.d auto.today for £100.
when i started the engine the morning at the pre-owners home,the car started right away.when its idoling the engine shakes side 2 side.
i knew the pre-owner as we where taxi drivers.this car has been a taxi hence the 250.000 miles.he had been told it could be the elec-accelartor and he bought one £80 and fitted it but never sorted the shaking out.i took it to my brothers garage to do mot work on it and within 30.mins of driving ,it cut out 4 times when stopping at lights.when in the garage i lifted the bonnet ,and on the right hand side where the filter is housed ,one pipe that goes down under the filter seems to be leaking fuel,could this be the problem,also as you look at the engine ,at the back across the back there is a plastic pipe on the left hane side with what looks like a mini filter on the end of it and not attached to anything,and on the right hand side of the engine there is another plastic pipe that bends left to the back of the engine not attached to anything either .
can anyone help me out.
 
Last edited:

turbopete

Senior Member
Joined
Feb 4, 2009
Messages
14,204
Reaction score
328
Age
46
Location
Spennymoor
Your Mercedes
2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
hi and welcome to the forums!

yes. replace any filters and sort any fuel leaks out and thid engine should be sweet despite its mileage! cant comment on the pipes hanging loose without seeing them though
 
OP
K

kirkbylads

New Member
Joined
Jul 17, 2009
Messages
3
Reaction score
0
  • Thread Starter
  • Thread starter
  • #3
hi and welcome to the forums!

yes. replace any filters and sort any fuel leaks out and thid engine should be sweet despite its mileage! cant comment on the pipes hanging loose without seeing them though

i have replaced one of the fuel pipes coming from the filter that had a leak today.started the car up and its still bouncing ,and when you rev it up,it cuts out,i spoke to the previous owner and he said he had it put on the computer and it found that the elec throttle was showing error codes,so he bought one cost him £80.and it was still bouncing around,he also said it had to be plugged back into the computerso the error codes can be wiped of.i spoke to a auto electrition today and he said it did,nt need it ,just disconnect the battery for 20mins and thatwill do.we tried that but still the same.
can anyone add any other idea,s.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
All of the injectors need checking for the spray pattern etc to start with
 

Number_Cruncher

Senior Member
Joined
Oct 10, 2007
Messages
1,806
Reaction score
2
Your Mercedes
1995 W124 E300D TE
All of the injectors need checking for the spray pattern etc to start with

Yes, the OP should fix the obvious fuel leaks first.

Then, with the engine ticking over, slacken each injector pipe in turn. If one injector makes no difference, that cylinder isn't firing properly.

If the OP does find one cylinder not firing, I would temporarily swap its injector with a neighbouring cylinder to see if the missfire moves with the injector, or is cylinder specific. Be sure to renew the injector seals every time the injector is re-installed - it's easy to ruin a good injector very quickly.
 


The SL SHOP YOUR ONE STOP SHOP FOR ALL THINGS SL, SERVICE & RESTORE, SALES, HIRE & PARTS
Choose from a wide range of superbly prepared SL’s each with a 12 month guarantee. We can service, update, re-trim, restore and repaint your 107 SL.
Choose from a 6 or 8 cylinder car for the day, the weekend, a month or a year. Contact us for a wide range of parts. Tel: 0844 414 2116 or visit our website atwww.theSLshop.com
Top Bottom