1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Instrument cluster dies when using key fob

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by hs500, Mar 20, 2012.

  1. hs500

    hs500 New Member

    Messages:
    6
    Likes Received:
    0
    Joined:
    Feb 3, 2007
    W203 2001 has a very peculiar problem, the key fob has started developing a problem and I am unable to unlock steering wheel and turn the ignition at times. When I do manage, the entire instrument cluster and the electrics stop working, like radio, indicators, electric windows, but the car runs as normal except that the radiator fan starts immediately. Anyone else had this problem?
     
  2. Miffy

    Miffy Senior Member

    Messages:
    7,356
    Likes Received:
    2
    Joined:
    Sep 6, 2008
    Location:
    Bromley, London
    Your Mercedes:
    CLK 320 CAB Elegance C208
    I think first stop is your local indie to get your codes read
     
  3. Roney

    Roney New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Nov 21, 2012
    Location:
    Worcester UK
    Your Mercedes:
    E320 CDI Sport 2005
    Hi HS 500 my car (E320CDI Sport W211 2005) has just developed the same problem. My independant has had the Instrument cluster recon'd by AC tronics and my local MB dealer has replaced the ignition switch. The problem still exists did you get your's sorted?
     
    Last edited: Nov 21, 2012
  4. WG M-B

    WG M-B Senior Member Authorised Forum Supporter

    Messages:
    3,105
    Likes Received:
    6
    Joined:
    Dec 5, 2010
    Location:
    North west london
    Your Mercedes:
    C63 Wagon in black
    So the steering lock does not release but the vehicle starts????????
     
  5. Roney

    Roney New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Nov 21, 2012
    Location:
    Worcester UK
    Your Mercedes:
    E320 CDI Sport 2005
    No, in my case the steering lock is released, the car starts in the normal way but then the display and electrics die & the engine fan races. Invariably, when I switch off release the key then start the car again it is fine.
     
  6. WG M-B

    WG M-B Senior Member Authorised Forum Supporter

    Messages:
    3,105
    Likes Received:
    6
    Joined:
    Dec 5, 2010
    Location:
    North west london
    Your Mercedes:
    C63 Wagon in black
    Do you get an ESP warning also???
     
  7. Mark@RMK

    Mark@RMK Senior Member Authorised Forum Supporter

    Messages:
    534
    Likes Received:
    8
    Joined:
    Jan 4, 2010
    Location:
    Birmingham
    Your Mercedes:
    115CDi Vito
  8. Roney

    Roney New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Nov 21, 2012
    Location:
    Worcester UK
    Your Mercedes:
    E320 CDI Sport 2005
    No, ESP warning, I have had the new ignition lock and Keys re coded,
     
  9. Mark@RMK

    Mark@RMK Senior Member Authorised Forum Supporter

    Messages:
    534
    Likes Received:
    8
    Joined:
    Jan 4, 2010
    Location:
    Birmingham
    Your Mercedes:
    115CDi Vito
    But not the key?

    The key is not letting circuit 15r turn on.

    Fixed over 30 of the same cars with the same fault


    Mark
     
  10. Roney

    Roney New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Nov 21, 2012
    Location:
    Worcester UK
    Your Mercedes:
    E320 CDI Sport 2005
    Still got problem, someone out there must have a solution. The main dealer hasn't.:(
     
  11. grahamcol

    grahamcol Senior Member

    Messages:
    1,458
    Likes Received:
    322
    Joined:
    Jan 12, 2009
    Location:
    West Midlands
    Your Mercedes:
    2001 SLK230, 2007 CLK220 CDI
    Why not contact Mark @ RMK as above ? Seems to know what he's on about and I believe he has a good reputation.
     
  12. Roney

    Roney New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Nov 21, 2012
    Location:
    Worcester UK
    Your Mercedes:
    E320 CDI Sport 2005
    Hi Graham, I have and they were very helpfull, however problem still exists, I now think it may be the ECU?
     
  13. grahamcol

    grahamcol Senior Member

    Messages:
    1,458
    Likes Received:
    322
    Joined:
    Jan 12, 2009
    Location:
    West Midlands
    Your Mercedes:
    2001 SLK230, 2007 CLK220 CDI
    Oh dear. Sorry, I hadn't realised you'd made contact with him. The only other thing I can think of is trying the indie I go to. Ex MB and even the main dealers send cars to him they're unable to fix. That's assuming Walsall's not too far for you to go. His name is Marc of ACMS Mercedes. 07530 456000 / 01922 634666, he's highly recommended by me and everyone else who uses him. Good luck.
     
  14. Roney

    Roney New Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    Nov 21, 2012
    Location:
    Worcester UK
    Your Mercedes:
    E320 CDI Sport 2005
    Thanks Graham for the info, I will do if all else fails. My Indie has currently got it to test the ECU.
     

Share This Page