Limped home. :-(

FarmerDan

Active Member
Revs wouldnt go above 2k and temp shot up!
Did find air intake pipe hanging off behind the grill. That can't be good!?
 

oigle

Senior Member
Revs wouldnt go above 2k and temp shot up!
Did find air intake pipe hanging off behind the grill. That can't be good!?

I'd be worried about the temp shooting up !!!!! That needs sorting asap. Maybe that will then remedy the apparent limp mode.
 
OP
F

FarmerDan

Active Member
I think I'm paranoid now!
After much bad language, scratches and kicking things around the garage the pipe was back on, but temp was still higher than I would like - 80ish.
The car ran better but if I gave it the beans it sounded like the heater came on in the car! Weird!!
 

oigle

Senior Member
I think I'm paranoid now!
After much bad language, scratches and kicking things around the garage the pipe was back on, but temp was still higher than I would like - 80ish.
The car ran better but if I gave it the beans it sounded like the heater came on in the car! Weird!!

If it is only 80ish, that is where it ought to be, so no worries there. The noise you are hearing is probably escaping boosted air. You need to find the leak - split inlet hose or something similar.
 
OP
F

FarmerDan

Active Member
Went away Friday / Sat and left the merc on the driveway in shame!
Been out for a 30 mile spin. Would judder from time to time and at 20 miles the limp mode thing kicked in. Temp went I would say nearly to 90 and dropped to 60 when limping home.
Still sounding like the blowers kick in on the windscreen when I accelerate hard.
Off to the garage tomorrow. Any recommendations??
 

roofless

Senior Member
it sounds just like the heater blower but as above it's a split in one of the induction pipes ....see below 20-30 or 50






50
 

oigle

Senior Member
Went away Friday / Sat and left the merc on the driveway in shame!
Been out for a 30 mile spin. Would judder from time to time and at 20 miles the limp mode thing kicked in. Temp went I would say nearly to 90 and dropped to 60 when limping home.
Still sounding like the blowers kick in on the windscreen when I accelerate hard.
Off to the garage tomorrow. Any recommendations??

Just another point - your thermostat is obviously bu99ered too. No way it should drop to 60° when "limping home". A good therm will go to 85° and stay there under just about any conditions.
 
OP
F

FarmerDan

Active Member
NEWS JUST IN - Split hose. Replacement on its way. :)
Oil in coolant header tank :-(
Tested for gases in the radiator came up clear so looks like knackered oil cooler. Unfortunate but could have been worse! A lot worse!!
 
OP
F

FarmerDan

Active Member
Well she's spending the night in the garage and will hopefully be released into the wild tomorrow when no doubt I will be some what lighter in the pocket.
Fingers crossed it's fixed it!
 
OP
F

FarmerDan

Active Member
All I can say is wow!
I thought the car was quick before... I'm sure the garage have installed a warp drive now!
Perhaps it's just down to my wallet being lightened?!
Oh and the temperature seems stuck on 80 now, so all good now I hope!
 
Top