1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Owning CLS W219

Discussion in 'General Mercedes-Benz Related Discussion' started by Gregor, Apr 18, 2016.

Tags:
  1. Gregor

    Gregor Active Member

    Messages:
    27
    Likes Received:
    0
    Joined:
    Dec 26, 2014
    Location:
    Edinburgh
    Your Mercedes:
    CLS / 2006 / 320 CDI
    Hello everyone

    Just wanted to ask you for your experience and opinion about owning CLS W219.

    I own 320CDi 2006 75k millage for last 3 years and are at the point when I find myself with two options. First make a long term commitment and stay with a car (as i love the look and can forgive painful lack of folding rear seats) and other sell it and buy let’s say Suzuki Grand Vitara.

    I’d like to find out from you, what type of repairs did you make and what went wrong in your cars in similar age/milage so I can calculate what is statistically ahead of me and make a decision.

    I guess there is a standard list of things which go wrong and let me take you these which I ticked off already. I exclude services and things like break pads etc.

    I fixed:
    1. Front coil spring
    2. Coil spring (replaced before I bought the car - not sure which one)
    3. Plugs relay
    4. I replaced the seals next to turbo - these which case leak of oil into shutter motor and puts car in limbo mode.
    5. Rear parking sensor
    6. Squeaky noise from front right wheel (infection of WD40 into rapper seal helped)

    I did not fixed
    1. the rear window defroster (fuse OK and apparently it’s the fault of cables / connect with melted in fuse box in the boot)
    2. front parking sensor (problem in rainy days - apparently would need to remove whole bumper)

    First symptoms:
    1. This winter in cold condition I had on several occasions EPS malfunction error.
    2. When turning a wheels and reversing there is a loud knock sound heard from front right suspension. As well when driving for longer and then breaking on slow speed sort of rusty noise can be heard.
    3. During hot days, left front window doesn’t want to close
    4. from time to time passenger mirror do not fold or driver mirror do not unfold
    5. From day one the gearbox especially when cold can be jerky or very early stuck on one gear.

    So, what’s yours and what age/millage they appeared ?
    cheers guys
     
  2. Rotorhead500

    Rotorhead500 Senior Member

    Messages:
    4,605
    Likes Received:
    974
    Joined:
    Oct 19, 2012
    Location:
    Very South Devon
    Your Mercedes:
    Used to have a C63...
    Hello!

    Ran a 57 reg for 2 yrs and 20k miles - absolutely loved it (always liked the CLS when it launched), and only things I had done was number 5 injector seal (was supposed to be done at point of sale but the MB stealer were useless!), and front passenger window regulator lubricated (window regs are a common fault apparently).

    Was actually looking to get a 218 but got a bit distracted.

    Would have another CLS in a flash.

    Ref your gearbox, the 7g on mine was a bit like when cold, and on 2-1 down shifts in particular. Once warm it was very smooth, but I did a precautionary fluid change anyway, and it did improve the cold performance.
     
    Last edited: Apr 18, 2016
  3. Tigerade

    Tigerade Active Member

    Messages:
    25
    Likes Received:
    0
    Joined:
    Feb 21, 2016
    Location:
    Blackpool
    Your Mercedes:
    CLS 320 Diesel
    I have a CLS 320 2006 MY, since in my ownership in February and under the warranty its had the following: Number 2 Glow plug, Front parking sensors, O/S/F wishbone, B-Service, 02 Sensors, Air flow meter, and now currently having a Washer bottle level fault sorted and seeing as it's wired in series with Coolant sensor that's been done too. Before I purchased the car it had discs and pads all round along with tyres.

    I'm waiting to find out if the garage have now cured my washer level sensor faults, but after all that I do a 516 mile commute every week and I love it, the car is currently on 86k miles.

    My only bug bear is a lack of cup holder.
     
    Last edited: Apr 18, 2016

Share This Page