1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rain sensor retro fit.. the start

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by S.Speed, Oct 18, 2012.

  1. S.Speed

    S.Speed Senior Member

    Messages:
    5,063
    Likes Received:
    6
    Joined:
    Apr 12, 2009
    Location:
    Lancashire
    Your Mercedes:
    Saab 9-3
    I have been brooding over retro fitting a rain sensor to my car for a while..
    Its one of those optional extras that you don’t need…. Until you have had cars with them!

    I originally got the idea via Whitenemisis from the following link: (So a big thank you to Peter)..:D

    http://www.mbclub.co.uk/forums/elec...etrofit-without-screen-change.html#post815606

    I have managed to source the impossibly difficult part to get, and that is the lens unit..
    Remember that “officially” you are supposed to replace the screen in order to have the lens assembly..
    Anyone interested can try here (only 1 left though and I cant say if they will get more)..

    http://www.ebay.co.uk/itm/110932013145?ssPageName=STRK:MEWAX:IT&_trksid=p3984.m1423.l2649

    I decided against eBay for the actual sensor control unit as I wanted to be sure I got the correct one for the facelift version of the 203.

    I phoned my local dealership and he was very helpful indeed.. I shall receive it on Saturday morning for the princely sum of £44
    Sorry but I don’t have the part number for this..I will do on Saturday though.

    Tonight I took the bull by the horns and set to work removing the old sensor.

    If you are going to do this then a certain amount of bravery is needed..

    I thought to myself, “If it comes to it then I need a new screen, but that’s not the end of the world”..

    The sensor is glued with an extremely sticky rubbery type glue..
    I sharpened a ½” bevel edged chisel and then got some duck oil..
    My idea was to spray the duck oil and then slice through the glue in stages.. Without the duck oil the glue kept re attaching itself..
    If you are going to try my method the as you slice under the plastic mount pull away from the screen. You need to try not to put excess force on the actual glass with the corner of the chisel…

    My sensor seems different to the one in the link as it has 4 wires and not 3 !!
    On the original post via Whitenemisis there was need of a small extra loom..
    I’m hoping its not needed in my case

    I know its not quite plug and play as it will need to be coded via STAR

    Photo 1. Shows the screen as it was with the sensor in place
    Photo 2. Shows the interior with sensor and bracket
    Photo 3. Shows the screen exterior with sensor and bracket removed.
    Photo 4. Shows Interior of screen with sensor and bracket removed.
    Photo 5. Shows a close up of the plug that goes into the sensor.. As you can see mine has 4 wires with totally different colours


    The lens is on its way and I collect the sensor on Saturday..
    Then I need to arrange for coding.
    So I cannot tell you all how successful (or not) this has been until that point.
    I shall keep you all updated though..
     

    Attached Files:

    Last edited: Oct 18, 2012
  2. whitenemesis

    whitenemesis Senior Member

    Messages:
    17,978
    Likes Received:
    22
    Joined:
    Dec 21, 2006
    Your Mercedes:
    CLS55 AMG '05
    Nice one Simon!

    The loom you have is the same as the one I had to replace (well, I left it tucked up in the headlining) and looks the same as Wully's in post #2 in the first link. I ended up getting the loom that Wully shows in post #6 and plugging it into the spare socked in the OCP module.

    I think the purple wire is for data, something that was absent from the simple light sensor. It will be interesting how you get on.
     
  3. OP
    S.Speed

    S.Speed Senior Member

    Messages:
    5,063
    Likes Received:
    6
    Joined:
    Apr 12, 2009
    Location:
    Lancashire
    Your Mercedes:
    Saab 9-3
    Thank you Peter..
    I will order the loom and plug tomorrow...:D
     
  4. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Just so that you know,,, when I had the new screen in the SL, it took me 6 goes to get STAR to set it correctly
     
  5. whitenemesis

    whitenemesis Senior Member

    Messages:
    17,978
    Likes Received:
    22
    Joined:
    Dec 21, 2006
    Your Mercedes:
    CLS55 AMG '05
    Took my dealer 15min to code..
     
  6. whitenemesis

    whitenemesis Senior Member

    Messages:
    17,978
    Likes Received:
    22
    Joined:
    Dec 21, 2006
    Your Mercedes:
    CLS55 AMG '05
    Simon did you leave the sensor frame attached to the screen? It's hard to see in you pictures
    [​IMG]
    [​IMG]
     
  7. OP
    S.Speed

    S.Speed Senior Member

    Messages:
    5,063
    Likes Received:
    6
    Joined:
    Apr 12, 2009
    Location:
    Lancashire
    Your Mercedes:
    Saab 9-3
    Hi Peter.
    No I did not.
    In theory the new lens comes with the frame.
    If it doesn't then I will just have to order it.
    To be honest when I was removing to sensor bracket I didn't realise that it seperated.
    I phoned the dealership today and ordered the loom and plug.
    He said those would be in tomorrow for when I pick up the sensor.
     
  8. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Mine took 6 goes and only took 5½ mins :D and I do it in the comfort of my own home :D
     
  9. OP
    S.Speed

    S.Speed Senior Member

    Messages:
    5,063
    Likes Received:
    6
    Joined:
    Apr 12, 2009
    Location:
    Lancashire
    Your Mercedes:
    Saab 9-3
    Hi Malcolm.
    Pity I am so far from you.
    I am toying with the idea of visiting Comand online whilst down at the Holt GTG.
    It depends on the competence (or otherwise) of my local dealership with STAR.
    Luckily the parts guy has become a friend and so he puts himself out for me.
     
  10. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    If you get it all done for the Xmas meet I can bring STAR with me :D but knowing you you will be anxious to get it working, it is a shame you are so far away,,, I could spend many a happy hour with you
     
  11. OP
    S.Speed

    S.Speed Senior Member

    Messages:
    5,063
    Likes Received:
    6
    Joined:
    Apr 12, 2009
    Location:
    Lancashire
    Your Mercedes:
    Saab 9-3
    I shall keep you informed Malcolm.
    I would be very grateful to you if you could "STAR" it.
    If I haven't managed to get it sorted before the meet up then yes please to you sorting it for me.
    S.
     
  12. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    I will let Cole do it, he is 1053 times faster than me :D:D
     
  13. OP
    S.Speed

    S.Speed Senior Member

    Messages:
    5,063
    Likes Received:
    6
    Joined:
    Apr 12, 2009
    Location:
    Lancashire
    Your Mercedes:
    Saab 9-3
    Well its fitted today..
    However I need to get it coded so until that point I cant say if its a total success...
    If you are going to try this then be VERY AWARE that the sticky stuff that sticks the lens to the screen is EXTREMELY sticky !!
    Think of it as a contact adhesive SO YOU GET ONE CHANCE TO BE ACCURATE with the placement of the lens..
    Luckily I am highly skilled, competant (and modest) and so 1 chance was all I needed:D

    However.......
    The Holder (part number: A203 820 1511) is NOT available from mercedes.. It only comes with the windscreen..

    So because i had removed the holder in order to do a thorough job of getting all the old adhesive off, I am a bit snookered..
    BUT the holder is purely for holding on the cover to the rear of the sensor and to be honest I really am NOT that bothered about it.. The rear of the sensor cannot be seen whilst driving, nor can it be seen from outside and so I shall leave it as is (until my screen accidentally gets a crack)..

    Oh I have some very surprising news re Windscreens.... For the 203 with Rain sensor it is £161 from the MB dealership !!
    I am flabbergasted by that..I thought it would have been at least double that amount !!

    Below are some more photos...
    1st photo shows the exterior of the screen with the "official" sensor..
    2nd photo shows the actual sensor behind the rear view mirror.
    3rd photo is the part number for the latest sensor (manufactured circa 3 months ago)..
     

    Attached Files:

    Last edited: Oct 20, 2012
  14. whitenemesis

    whitenemesis Senior Member

    Messages:
    17,978
    Likes Received:
    22
    Joined:
    Dec 21, 2006
    Your Mercedes:
    CLS55 AMG '05
    Well done Simon, excellent result!

    Regarding the holder, if you find you do want to fit it could you not get it from the same place you bought the lenses? Or perhaps refit the original?
     
    Last edited: Oct 20, 2012
  15. OP
    S.Speed

    S.Speed Senior Member

    Messages:
    5,063
    Likes Received:
    6
    Joined:
    Apr 12, 2009
    Location:
    Lancashire
    Your Mercedes:
    Saab 9-3
    I shall send a question to them Peter..
    But if I cant then its not the end of the world..
    Seriously, you really have to look for it to see its missing...

    When I disconnected the original sensor I went to pick up the bits and pieces from the dealership and straight away I got an error message telling me to visit the dealers cos the sensor was inoperative..

    The very hardest part of the new sensor was re fitting the plug..
    I nearly made myself cross eyed !!:shock:
     
    Last edited: Oct 20, 2012
  16. whitenemesis

    whitenemesis Senior Member

    Messages:
    17,978
    Likes Received:
    22
    Joined:
    Dec 21, 2006
    Your Mercedes:
    CLS55 AMG '05
  17. OP
    S.Speed

    S.Speed Senior Member

    Messages:
    5,063
    Likes Received:
    6
    Joined:
    Apr 12, 2009
    Location:
    Lancashire
    Your Mercedes:
    Saab 9-3
    Hi Peter,
    Sorry for the delay..
    You got me thinking and so Ive just been out for a quick drive to test..

    Oh dear.. There is an error message telling me that the windscreen sensor is innactive..
    Before I tried it without starting the engine and i got no error code...

    Am I right in assuming that once its coded then all should be well ?
    The wipers are just plain intermittant and not auto..
    I turned on the headlights onto the Auto position and they lit... I tried shining a torch onto the sensor but the headlights remained lit..
    I would say that at this moment in time the car cannot "see" the rain sensor..
    Does this make sense?
     
    Last edited: Oct 20, 2012
  18. OP
    S.Speed

    S.Speed Senior Member

    Messages:
    5,063
    Likes Received:
    6
    Joined:
    Apr 12, 2009
    Location:
    Lancashire
    Your Mercedes:
    Saab 9-3
  19. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    With out the coding, this could be the problem, the gain of the set up has to be set so that the prism is focussed, this must be the same for the light sensor.

    I might have told you this before but,

    The screen box contains a sender LED and a receiver that shine through the prism. when the screen is dry, the receiver picks up the beam and max current flows, when rain or light falls on the screen, it puts the beam out of focus, the current drops and allows the wipers to run, or what ever is on the light function to work, if it is not focussed, then it cannot work, so with luck it just needs setting up.
     
  20. OP
    S.Speed

    S.Speed Senior Member

    Messages:
    5,063
    Likes Received:
    6
    Joined:
    Apr 12, 2009
    Location:
    Lancashire
    Your Mercedes:
    Saab 9-3
    Thank you Malcolm..
    Thats what I am hoping it is...
    Not sure whether to risk the MB dealership (only to be told it cant be done) or just wait until the meetup...
     

Share This Page