1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Starting problem ??????????

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by luisc240, Mar 19, 2009.

  1. luisc240

    luisc240 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Nov 16, 2008
    Location:
    Cambridge
    Your Mercedes:
    C240 2.6L petrol
    :confused: HI my c240 2.6 petrol w203 from 2001 didn´t start in the morning.
    Called the AA's and they couldn´t find anything wrong with the car. :(
    2nd time called them to tow the car to a garage but another AA mechanic said that there´s a fuel problem or either the pump or possibly another reason. He removed the back seat and said he couldn´t hear the pump working. So as for now still parked on my driveway decided to do some more research and I was wandering if any of you guys can advise me on what to do and how to check if it is really the fuel pump.
    I did try all the options that I could remember like battery, fuses, start motor etc but dont know how to check relays and there´s no warning lights. Not taking it to mercedes, hopefully, as they charge an arm and a leg just for a diagnosis and might be something silly that will costme a fortune.
    Thanks in advance.
    Luis
     
  2. Cole@MBS

    Cole@MBS Forum Supporter Authorised Forum Supporter

    Messages:
    13,533
    Likes Received:
    602
    Joined:
    Dec 1, 2008
    Location:
    Hedge End, Southampton
    Your Mercedes:
    124 300 CE 24 Coupe, 209 240 CLK
    welcome!

    First thing to check is the fuse for the pump, thats the 20amp number 4 down in the rear sam (fuse board), if thats ok then i suspect the pump itself, or the wiring from the rear sam, pump causes the plug to melt and duffs the wiring up,
     
  3. Cole@MBS

    Cole@MBS Forum Supporter Authorised Forum Supporter

    Messages:
    13,533
    Likes Received:
    602
    Joined:
    Dec 1, 2008
    Location:
    Hedge End, Southampton
    Your Mercedes:
    124 300 CE 24 Coupe, 209 240 CLK
    I think i have a rear sam and fuel pump for your car sitting in the shed!
     
  4. OP
    luisc240

    luisc240 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Nov 16, 2008
    Location:
    Cambridge
    Your Mercedes:
    C240 2.6L petrol
    hi

    thanks for the reply
    checked all that and the relay aswell
    i did swap just now the relays and samething nothing happens.
    if you got one and it´s suitable i would be a very happy man if we would get to arrange something because all the part suppliers said they wouldn´t hav them in stock and no one even told me how much they where.
    i hope that it´s a easy fit thing.
    many thanks
    Luis
     
    Last edited: Mar 19, 2009
  5. Cole@MBS

    Cole@MBS Forum Supporter Authorised Forum Supporter

    Messages:
    13,533
    Likes Received:
    602
    Joined:
    Dec 1, 2008
    Location:
    Hedge End, Southampton
    Your Mercedes:
    124 300 CE 24 Coupe, 209 240 CLK
    Sent you Private mail!!
     
  6. OP
    luisc240

    luisc240 New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    Nov 16, 2008
    Location:
    Cambridge
    Your Mercedes:
    C240 2.6L petrol
    ok

    thanks.
    I'll wait for it.
    hotmail can take a bit and i´ll get back to u asap.
    cheers
     
  7. Cole@MBS

    Cole@MBS Forum Supporter Authorised Forum Supporter

    Messages:
    13,533
    Likes Received:
    602
    Joined:
    Dec 1, 2008
    Location:
    Hedge End, Southampton
    Your Mercedes:
    124 300 CE 24 Coupe, 209 240 CLK
    Sent you private message on hear, top right hand coner says messages, you should have one!
     

Share This Page