Vito 112CDI problem

m2X123

New Registration
Joined
Oct 15, 2009
Messages
1
Reaction score
0
Hi,
I have a question about my 2003 Vito 112CDI,
When I accelerate there is a schwooshing sound that starts at around 2000RPM, this gets worse the harder I push on the throttle and eventually turns into a sort of squeal, as if air is leaking out from somewhere and the pressure of it builds up as I give gas. I'm not very good at engines and all that so I was hoping some of you here have an idea of what it might be, I'm kind of worried it might be the turbo or something, but like I said, I don't know.
 

Wirral_guy

Active Senior Members
Joined
Jul 12, 2009
Messages
998
Reaction score
0
Age
56
Location
Ness, nr Chester
Your Mercedes
2004 CLK270cdi Avantgarde
I have a different engine but I had a similar noise on mine when I took it for a test drive. Mine sounded as though the heater fan was speeding up as I accelerated, like a huge whoosh of air but only when the car was being driven, not when stationary.

The cause, and simple fix, was a blown pipe off the EGR valve. Re-attached the pipe and all was well.

Not sure if it is the same problem but sounds very similar.

Dave
 
A

andy@pcd-ltd

Guest
It could well be a split pipe or maybe the cat is blocked on it.

Are you experiencing any form of lack of power
 

stu2009

Active Member
Joined
Sep 12, 2009
Messages
34
Reaction score
0
Location
Brighton, East Sussex
Your Mercedes
Vito 112 cdi
Check all pipe work between the turbo and inlet manifold. It may also be a broken airline behind the headlight level adjustment. I had a noise like you describe and it turned out to be a badly fitted air filter.
 
Top Bottom