1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

W124 E200 blower stopped working.

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Mercebean, Oct 22, 2012.

  1. Mercebean

    Mercebean New Registration

    Messages:
    1
    Likes Received:
    0
    Joined:
    Oct 22, 2012
    Location:
    Dorset
    Your Mercedes:
    w124/1994/e200
    Blower stopped working over the space of a week, heat still comes out but no air. Have searched forums and people suggesting 30amp fuse either behind speedo or under bonnet near left wheel arch cannot find either of these nor anything connected with blower in fuse box next to relay. I have pulled everything out in driver and passenger foot well. Cannot find how to remove centre console... Worried about ripping anymore out as it might not go back? Any suggestions greatly appreciated :)
     
  2. Bolide

    Bolide Senior Member

    Messages:
    3,294
    Likes Received:
    4
    Joined:
    Sep 17, 2002
    Your Mercedes:
    BMW 525 Diesel Touring
    The fan is under the jump wiper and is accessed from the engine bay. The fuse is in the fusebox. You'll find lots of threads about W124 heater fans - just search the forum

    Nick Froome
     
  3. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    This could be one of those that do not come out through the top, as Nick the fuse is there, and the current drawn by these fans is quite high, a separate inline fuse may do better
     

Share This Page