1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

w140 CL420 windows

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by audiojohn0, Jan 28, 2012.

Tags:
  1. audiojohn0

    audiojohn0 Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Jan 28, 2012
    Location:
    Dublin, Ireland
    Your Mercedes:
    W140 CL420/1998/m119. W111 280SE/M130
    evening all

    having had many models of Mercedes over the years i acquired my first W140 CL420 recently, a superb car. i have what i believe is a common problem to the model. when the doors are closed, one of the rear windows will not rise to the fully closed position. if the door window is fully closed with the door open it overshoots its correct closed position by maybe half an inch. if i fool the car into thinking the door is shut by activating the lock, the rear window closes as it should when the door window is in this fully but overshot closed position. can anyone please advise on this - i have tried the owners manual solution as if the battery had been disconnected but to no avail?

    many thanks in advance

    JOHN
     
  2. Mic

    Mic Senior Member

    Messages:
    4,271
    Likes Received:
    128
    Joined:
    Nov 12, 2009
    Location:
    Oxfordshire
    Your Mercedes:
    MB SL500(2003), MB SLK320(2001), Volvo V70 XC AWD(2001)
    Hello and welcome.....great choice of car.....help WILL follow

    Mic
     
  3. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    318
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    First disconnect the battery for 15 mins (do have the radio code handy) the try and memorize them again. When ready and you connect up again all windows will be mid way.

    Turn the ignition on, close each front window on the slow close lift button (not pressed right hard down) till closed and hold the switch for 5 seconds after the window has closed, then close the rear ones and do the same. do the same on the sun roof.

    See how this goes,,,if no good I want more details and I have just completely re adjusted all of my windows so there is no wind noise at all.
     
  4. OP
    audiojohn0

    audiojohn0 Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Jan 28, 2012
    Location:
    Dublin, Ireland
    Your Mercedes:
    W140 CL420/1998/m119. W111 280SE/M130
    thanks Malcolm. i will try this but in what position should the windows be when the battery is disconnected?
     
  5. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    318
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    The windows will stay as the were once the battery is disconnected, after the 15 min and you re connect they will all drop half way, and you then do the re set as above by just pressing gently on the close switches and not all the way down
     
  6. OP
    audiojohn0

    audiojohn0 Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Jan 28, 2012
    Location:
    Dublin, Ireland
    Your Mercedes:
    W140 CL420/1998/m119. W111 280SE/M130
    many thanks again Malcolm. As soon as the rain stops i will give this a try and report back!

    JOHN
     
  7. OP
    audiojohn0

    audiojohn0 Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Jan 28, 2012
    Location:
    Dublin, Ireland
    Your Mercedes:
    W140 CL420/1998/m119. W111 280SE/M130
    Result!

    Good afternoon Malcolm

    its eventually stopped raining and i have tried that now and all seems to have worked perfectly, many thanks. might i ask your opinion on another what i understand is a common problem on these vehicles, the Parktronic system. if switched on regardless of proximity it is in a default mode of showing the first two bars. i gather that even one sensor out can cause this but short of a diagnostics test is there anything else can be more easily checked - impedance of sensors?

    Thanks again

    JOHN:p
     
  8. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    318
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Pleased the window are OK now. :D


    I use a lollipop type stick and hold it over each sensor in turn, with the aid of someone watching the display you can cover each one in turn and find the one that is giving the problem, it gives you the range of the sensors via the display so the stick can be held at the correct distance or you have the car plugged into STAR
     
  9. JEZ.S320L

    JEZ.S320L Active Senior Members

    Messages:
    2,804
    Likes Received:
    3
    Joined:
    Aug 18, 2007
    Location:
    Costa Calida, Spain
    Your Mercedes:
    Lincoln Navigator and a S320L Business Edition
    The wind noise didn't come from the windows...!!!! :p
     
  10. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    318
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    I would never do that in an S class ;)
     
  11. OP
    audiojohn0

    audiojohn0 Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Jan 28, 2012
    Location:
    Dublin, Ireland
    Your Mercedes:
    W140 CL420/1998/m119. W111 280SE/M130
    Hi Malcolm

    my w140 cl420 which you kindly advise on before has developed a strange problem which i imagine you will have the answer for immediately! the auto close function of the bootlid stopped working followed soon after by the doors. i did the 15 min battery ctrl/alt/del and which initially worked fine but on second attempt the bootlid had reverted. i noticed the car had being getting sluggish on start and at one stage after lying up needed a trickle charge so i put all this down to an out of condition battery dipping voltage on start up and upsetting matter so put in a new high capacity one at the weekend. car turns over much more vigorously now and again problem initially seemed sorted but has just come back. door function currently is fine - any ideas please?

    thanks Malcolm
     
  12. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    318
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Is the boot lid not self closing or taking a long time to lock
     
  13. OP
    audiojohn0

    audiojohn0 Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Jan 28, 2012
    Location:
    Dublin, Ireland
    Your Mercedes:
    W140 CL420/1998/m119. W111 280SE/M130
    not self closing. the lift handle retracts and it locks but no self close plus, the manual override latch that lets you manually fully close does not engage.
     
  14. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    318
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Pull the fuse in the trunk out and wait 1 min and put it back and try, its in the middle top f 9 I think it is marked
     
  15. OP
    audiojohn0

    audiojohn0 Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Jan 28, 2012
    Location:
    Dublin, Ireland
    Your Mercedes:
    W140 CL420/1998/m119. W111 280SE/M130
    that seems to have done the trick Malcolm. i hope it stays that way as it also did this with the battery disconnect which is essentially the same but a level higher in the sense of depowering everything. thanks again
     
  16. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    318
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    This may happen a few times to start with, it will eventually settle down once any moisture has been pumped out
     
  17. OP
    audiojohn0

    audiojohn0 Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Jan 28, 2012
    Location:
    Dublin, Ireland
    Your Mercedes:
    W140 CL420/1998/m119. W111 280SE/M130
    its doing something slightly different now and which is spreading to the doors. the boot closes fine after fuse out but slowly releases itself and i have noticed that the doors are doing that now, initially auto close then release a few second later - loss of vacuum?
     
  18. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    318
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    It could be a leak on a vacuum element, mine failed on the boot lock and this can upset it all, the pump will switch off again while like this.

    You need to listen to the pump in left hand side of boot, it should cut around 5 seconds after closing anything
     
  19. OP
    audiojohn0

    audiojohn0 Member

    Messages:
    22
    Likes Received:
    0
    Joined:
    Jan 28, 2012
    Location:
    Dublin, Ireland
    Your Mercedes:
    W140 CL420/1998/m119. W111 280SE/M130
    thanks again Malcolm
    i have never heard the pump run before although when it was working fine and the boot shut you could here this little "phut" discharge sound from around the back of the car. is the pump not under the drivers rear seat squab?
    john
     
  20. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    318
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Nope, the soft close pump is in the boot next to the CD changer, the locking pump is under the drivers side rear seat squab in a foam box
     

Share This Page