w220 2001 s320 cdi no start

billys320

New Registration
Joined
Apr 30, 2014
Messages
1
Reaction score
0
Location
west yorkshire
Your Mercedes
w220 s320 cdi
Hi peeps. major issues for this w220. here is what happened.
car just stopped when driving, no power, no crank.
been parked up for 4 months.
so had a look and got some fault codes.

After diagnostics with a Launch machine, rear sam unit was out. replaced,
also replaced front right sam, and front left sam just be sure as there was a little water ingress, but not a huge amount as this is a common issue.

There is no engine management light coming on in the dash when ignition is turned on, and no comms to ecu through scan tool.
Checked ecu power/ignition/earth, all ok, main relay does power up ecu.
Still no comms with ecu.

So direct fed kline from ecu to scan tool, logged into ecu, had a few codes. see attached.
deleted them and car started. still no engine management light showing on dash when ignition is turned on though.

car ran for 1 hour, the stopped again.

now cant get back into ecu, even if i direct feed kline to scan tool no comms.

all sam units are showing no faults.

if anyone can shed any light or has had similar issue, i would be grateful for any advise/help/ideas.

kind regards.
 

Attachments

  • IMG-20140430-00048.jpg
    IMG-20140430-00048.jpg
    128.7 KB · Views: 40


Prestige Motor Group is Hertfordshire's Premier INDEPENDENT MERCEDES BENZ SPECIALIST. We offer a service exceeding Main dealership expectations and HUGE savings on Main Dealership Prices. WE BEAT ANY GENUINE QUOTE! Prestige Motor Group pride ourselves on delivering excellent customer service as we believe the customer and the Car deserve the best.
Tel: 01462 672458www.prestigemotorsofhertfordshire.co.uk/
Top Bottom