1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2006 Viano CDI Ambiente phone cradle no power

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by fap, Jul 25, 2011.

  1. fap

    fap Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Nov 2, 2010
    Location:
    Dawlish, Devon, UK
    Your Mercedes:
    viano/2006/2.2
    I have a Viano CDI Ambiente 2006 with a phone cradle mounted on the dash near the steering. It is factory built and is the right connector for the Visee0 MB-2. I just bought a Viseeo MB-2 and connected it to the car cradle. No power to the unit. I tested the unit by connecting it to my PC and it picked up the phone, paired the devices. So the unit works. I called mercedes exeter to ask them if they kew anything about it as i read on another forum that sometimes those units were not connected (wired). All i got from them is: "Sorry, I don't know, we don't do much with Vianos.".
    Then the next one was "£120.00 for looking". I'm gutted. Once again I am stuck with £160.00 worth of kit, and no means to make it work.

    Anybody with an answer?
     
  2. 47p2

    47p2 Senior Member

    Messages:
    3,582
    Likes Received:
    4
    Joined:
    May 3, 2006
    Location:
    Scotland
    Your Mercedes:
    Slk
    Have an MB independent connect it to Star to find the problem
     
  3. OP
    fap

    fap Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Nov 2, 2010
    Location:
    Dawlish, Devon, UK
    Your Mercedes:
    viano/2006/2.2
    Hi John

    I leave in dawlish near Exeter (UK).
    I don't suppose you can point me in the right direction
     
  4. npuk

    npuk Guest

    Comand.co.uk are highly recommended and will be able to help but they are in Woking, Surrey.
     
  5. OP
    fap

    fap Member

    Messages:
    13
    Likes Received:
    0
    Joined:
    Nov 2, 2010
    Location:
    Dawlish, Devon, UK
    Your Mercedes:
    viano/2006/2.2
    Viano phone cradle update

    Ok
    Thanks to yall people for trying. After my call to mercedes and them tryin to lighten me down £200 (before any diagnostic !!) , I retraced the installs. we had them change the radio system for a Becker sat Nav system. It all worked well then, apart from the cd changer but that wasn't their fault as the Merc cd changer system isn't compatible with any other non merc systems (I read). Anyway, the becker was working with a Flash card so gigabytes of music anyway. It had the right canbus and all was fine. I just wanted my phone to work so the Viseeo MB-2 was ideal since I already had the right cradle.
    Anyway, after a lot of thinkin, i decided to remove the Becker and put back the old Audio 10 that came with the car. i didn't have to look very far. I soon as the Becker unit came out, I soon realised that half of the wiring was missing, The wole plug that deals with audio, phone ect was just missing...

    So to end this very bitter update, the old Audio 10 is back in the car, the Viseeo MB-2 works as expected, the CD changer is back on and the wife is really happy.

    Thanks Merc Exeter for your wonderful imcompetence...
    I still love Mercedes Benz though :confused:

    And thanks to this forum :p
     
  6. 47p2

    47p2 Senior Member

    Messages:
    3,582
    Likes Received:
    4
    Joined:
    May 3, 2006
    Location:
    Scotland
    Your Mercedes:
    Slk
    Glad you're sorted and thanks for the update
     

Share This Page