1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

C180 1998 Cutting out .. can you help?

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by Steve Merc, Jan 2, 2014.

  1. Steve Merc

    Steve Merc New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jan 2, 2014
    Location:
    Canterbury Kent UK
    Your Mercedes:
    C180 Auto 1998
    Hi

    I am new to the forum and look forward to hearing from you all! Can anyone help. My wife's C180 Auto 1998 has developed a strange problem. It has started cutting out while driving after about 30 min or so. It is running slightly hot but not overheating. The car engine stops and when you try to start the car turns over but doesn't start. AFTER 30 min or so car regains power and starts up. AA man advised to change water pump and drive belt which we did ? But problem persists..
     
  2. turbopete

    turbopete Senior Member

    Messages:
    14,204
    Likes Received:
    324
    Joined:
    Feb 4, 2009
    Location:
    Spennymoor
    Your Mercedes:
    2010 '60' Ford Mondeo 2.0TDCi Zetec (sorry)
    crank sensor would be my guess (CPS) as its a common issue.
     
  3. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    309
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Change the CPS the crankshaft sensor and with luck you should be just fine.

    Cheapest from any Bosch service center, you could ask ECP what they have.
     
  4. OP
    Steve Merc

    Steve Merc New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Jan 2, 2014
    Location:
    Canterbury Kent UK
    Your Mercedes:
    C180 Auto 1998
    Thank you TurboPete and Television I will get right on it and let you know..
     
  5. Bayda

    Bayda New Registration

    Messages:
    1
    Likes Received:
    0
    Joined:
    Mar 25, 2015
    Location:
    Johannesburg, South Africa
    Your Mercedes:
    C180/2000/1.8
    stops running

    @Steve Merc so did replacing the Camshaft sensor work? We have the same problem and been to the mechanic several times. After spending on everything but the ******* sink it still stops for no apparent reason? HELP
     
    Last edited: Mar 25, 2015

Share This Page