Lighting Problem

Trueblue1872

Senior Member
Joined
Feb 2, 2018
Messages
83
Reaction score
22
Location
Scotland, United Kingdom
Your Mercedes
W203/2004/1.8 Kompressor
Hello all, i hope you can help with this frustrating problem that is driving me mad.

(W203 C180 KOMPRESSOR 1.8 2004)

I recently changed out my signal bulbs for new ones and on inspecting all of the lights they seemed to be working fine. Recently a message has been appearing on my malfunctions i have included a picture.

It states to check "Tail Lamp Back up Lamp on" and another saying "Tail Lamp Check Bulb"

On seeing this i immediatly done this ensuring all off rhe bulbs where secure and the contact points clean and free from any corrostion. I also ensures the cables where all secure. The problem keeps occuring despite all of the lights working as they should?

This problem is driving me insane. If any of you could help it would be greatly appreciated.

 

LostKiwi

Senior Member
Joined
Aug 25, 2006
Messages
26,447
Reaction score
15,900
Location
Midlands / Charente-Maritime
Your Mercedes
'93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
On these cars when a bulb fails it switches on another bulb at a lower voltage to replicate the function of the failed bulb. You will need to remove the bulbs, check them all and replace any faulty ones. This is what "Tail Lamp Back up Lamp on" is about.
Visually you will think all the bulbs are working but they really aren't.
 
OP
Trueblue1872

Trueblue1872

Senior Member
Joined
Feb 2, 2018
Messages
83
Reaction score
22
Location
Scotland, United Kingdom
Your Mercedes
W203/2004/1.8 Kompressor
  • Thread Starter
  • Thread starter
  • #3
On these cars when a bulb fails it switches on another bulb at a lower voltage to replicate the function of the failed bulb. You will need to remove the bulbs, check them all and replace any faulty ones. This is what "Tail Lamp Back up Lamp on" is about.
Visually you will think all the bulbs are working but they really aren't.
That explains it then. Many thanks for your help Kiwi much appreciated. The bulbs are all in working order tho Kiwi thats what i mean ?
 

M80

Senior Member
Joined
Jan 21, 2006
Messages
4,369
Reaction score
1,298
Location
Derbyshire
Your Mercedes
Viano 639, 651 5sp Auto.
Unlikely, but is it possible that the lamp is inserted wrong way round so illuminating the brake light instead.
Although that should also bring up a failed brake light.
 
OP
Trueblue1872

Trueblue1872

Senior Member
Joined
Feb 2, 2018
Messages
83
Reaction score
22
Location
Scotland, United Kingdom
Your Mercedes
W203/2004/1.8 Kompressor
  • Thread Starter
  • Thread starter
  • #5
ye thats what i was thinking i have also as mentioned tested all the lights are working including the brake lights reverse light etc and they all are so im extremely confused by the.
 

M80

Senior Member
Joined
Jan 21, 2006
Messages
4,369
Reaction score
1,298
Location
Derbyshire
Your Mercedes
Viano 639, 651 5sp Auto.
Again unlikely, but the rear number plate fittings can be a nuisance on these, but that should be a different alarm.
 

M80

Senior Member
Joined
Jan 21, 2006
Messages
4,369
Reaction score
1,298
Location
Derbyshire
Your Mercedes
Viano 639, 651 5sp Auto.
In the past I've had similar alarms that have gone when I've fitted new and matching lamps, as though a lamp was drawing too much or too little current.
I do buy cheap lamps from a trade warehouse though, but not for the headlamps.
 
OP
Trueblue1872

Trueblue1872

Senior Member
Joined
Feb 2, 2018
Messages
83
Reaction score
22
Location
Scotland, United Kingdom
Your Mercedes
W203/2004/1.8 Kompressor
  • Thread Starter
  • Thread starter
  • #9
ye i thik i might get some more new bulbs maybe they are just ready to go out and thats what the error is
 

M80

Senior Member
Joined
Jan 21, 2006
Messages
4,369
Reaction score
1,298
Location
Derbyshire
Your Mercedes
Viano 639, 651 5sp Auto.
Straw clutching, have you tried starting the engine, let it settle for a couple of minutes before turning the lights on?
 

Uncle Benz

Senior Member
Joined
Mar 31, 2006
Messages
3,287
Reaction score
1,847
Age
50
Location
West Sussex
Your Mercedes
Mainly Mercedes
Unplug the connector to the rear lamp cluster and check all the pins are bright and shiny. Common for the earth pin to go black
 


AMF Automotive - We are an independent Mercedes-Benz and AMG specialist located in Dartford, with full Mercedes Diagnostic equipment. We offer a full portfolio of tuning options for AMGs and can cater for all your Mercedes needs.
Tel: 0203 384 4644www.amfmercedes.com/
Top Bottom