Loss of power & acceleration on slk r170

Miss sugar

New Member
Joined
Jul 4, 2013
Messages
9
Reaction score
0
Location
Norfolk
Your Mercedes
Mercedes slk 230 r170
Please, if anyone can help, you may save my day/week/year!
About a month ago, my Mercedes ( slk r170 230 kompressor automatic) started playing up. As I pulled into town it cut out, completely, (no engine or power but dash lights stayed on) I waited 5 mins then car started fine. Got it on diagnostics and. No issue found.
Then it happened again, maybe a week later. more embarrassingly I was waiting for tracking check, parked up and when went to put car on ramp, it would not start, at all. Instead the fan sounded like a jet engine (never heard it do this before).
Eventually kwik fit got it started and on the ramp. Where it got stuck again for hours :Oops:
Took it to the mechanic and again no codes or faults on diagnostics.
Did some research on forums and had my cps (crank shaft position sensor) replaced with a genuine Mercedes part... It seemed to work, for two weeks, until this week.
Here's where it got dangerous, I was driving along at 60mph, and lost all acceleration. When I pumped accelerator there was nothing, did this twice, still nothing. Got prepared for emergency stop , pumped accelerator again in a last chance hope and magically she jumped back to life.
This was two days ago. I had no problems yesterday, but today as I waited at the traffic lights she just cut out. But it did start straight away.
Listening to engine when in park mode, I hear a click when the car hits 2000 revs. Sounds like its coming from near the filter (driver side of engine bay).
I am scared to drive and in tears as I genuinely don't know what to do. Car seems to repair itself when it goes on diagnostics hence garage things I'm crazy. And I fear one day it will cut out at speed and cause an accident. Please, please can you help me?
Christina
:confused:
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I am wondering if a faulty CPS again
 
OP
M

Miss sugar

New Member
Joined
Jul 4, 2013
Messages
9
Reaction score
0
Location
Norfolk
Your Mercedes
Mercedes slk 230 r170
  • Thread Starter
  • Thread starter
  • #3
But it was only replaced weeks ago, from genuine merc part.
 

jibcl500

Senior Member
Joined
Oct 22, 2005
Messages
6,420
Reaction score
6
Age
54
Location
Cambridgeshire
Your Mercedes
CL500,ML55,SLK280
Oil in the loom, remove the plugs at the main engine ECU if full of oil thats your problem.

jib
 

Miffy

Senior Member
Joined
Sep 6, 2008
Messages
7,356
Reaction score
4
Location
Bromley, London
Your Mercedes
CLK 320 CAB Elegance C208
Are they checking your faults with STAR ? thats the official Mercedes Diagnostics. The reason I ask is that many faults are stored and can be read off by STAR but very little info comes through to cheaper generic scanners
 

jibcl500

Senior Member
Joined
Oct 22, 2005
Messages
6,420
Reaction score
6
Age
54
Location
Cambridgeshire
Your Mercedes
CL500,ML55,SLK280
Or a 2nd thought K40 relay bad solder joints cutting out the fuel pump.

get the car to me tomorrow if you like, CB6 3UL 07730 777596

jib
 
OP
M

Miss sugar

New Member
Joined
Jul 4, 2013
Messages
9
Reaction score
0
Location
Norfolk
Your Mercedes
Mercedes slk 230 r170
  • Thread Starter
  • Thread starter
  • #8
No it's not been checked on star, I'm scared to go into Mercedes because of the prices they charge. Do they do a diagnostics for free?
-jib, thank you but I live in central Norwich and I'm scared to drive it that far.
Christina
 
OP
M

Miss sugar

New Member
Joined
Jul 4, 2013
Messages
9
Reaction score
0
Location
Norfolk
Your Mercedes
Mercedes slk 230 r170
  • Thread Starter
  • Thread starter
  • #9
Jiffy- can the camshaft sensor leak? And is this the same part as the cam shaft position sensor?
 

jibcl500

Senior Member
Joined
Oct 22, 2005
Messages
6,420
Reaction score
6
Age
54
Location
Cambridgeshire
Your Mercedes
CL500,ML55,SLK280
Well get your local garage to check the ECU for oil, its in the box top right corner of engine bay, ECU is the one at the back with many plug connects.

If all good on ECU remove K40 its at the front in the same box and has several fuses on the top, remove it open the box and look for cracked solder joints, very common problem, resolder all joints and it should be good as new.

jib
 

Warrior

Senior Member
Joined
Feb 4, 2011
Messages
335
Reaction score
0
Location
Isle of Man
Your Mercedes
E320 CDI 03 (Now changed for Jag XF 3.0D S), & Chrysler Crossfire Roadster 04 (SLK in Drag)

jibcl500

Senior Member
Joined
Oct 22, 2005
Messages
6,420
Reaction score
6
Age
54
Location
Cambridgeshire
Your Mercedes
CL500,ML55,SLK280
I frequent the Chrysler Crossfire forum and there is a lot of info on there (Crossfires are SLK's) about bad solder on Relay Control Modules causing the exact problems you describe.

It looks like an easy fix with a soldering iron and very easy to get to.

I could be wrong but have a read of this anyway

http://www.crossfireforum.org/forum/tsbs-how-articles/38483-how-repair-relay-control-module-rcm-mystery-no-start.html

Ive resoldered too many K40's than I care to remember and im seeing a lot of oil in the loom issues to on the 230K engine.

jib
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Oil in the loom is not going to cause the engine to stop though and re start OK
 
OP
M

Miss sugar

New Member
Joined
Jul 4, 2013
Messages
9
Reaction score
0
Location
Norfolk
Your Mercedes
Mercedes slk 230 r170
  • Thread Starter
  • Thread starter
  • #15
Thank you i shall get those checked tomorrow :D
Fingers crossed I find it
 
OP
M

Miss sugar

New Member
Joined
Jul 4, 2013
Messages
9
Reaction score
0
Location
Norfolk
Your Mercedes
Mercedes slk 230 r170
  • Thread Starter
  • Thread starter
  • #16

Warrior

Senior Member
Joined
Feb 4, 2011
Messages
335
Reaction score
0
Location
Isle of Man
Your Mercedes
E320 CDI 03 (Now changed for Jag XF 3.0D S), & Chrysler Crossfire Roadster 04 (SLK in Drag)
Is this the equivalent of the k40 relay?

Yes I think it is also referred to as the K40, have a look at the photo's in the link and it shows how to access it, what to look for, and how to repair it
 
OP
M

Miss sugar

New Member
Joined
Jul 4, 2013
Messages
9
Reaction score
0
Location
Norfolk
Your Mercedes
Mercedes slk 230 r170
  • Thread Starter
  • Thread starter
  • #18
Guys I'm p1570 code on diagnostics
 

jibcl500

Senior Member
Joined
Oct 22, 2005
Messages
6,420
Reaction score
6
Age
54
Location
Cambridgeshire
Your Mercedes
CL500,ML55,SLK280
Ok did they remove the plugs on engine ECU and look for oil ? if not they need to as this could be the problem.

jib
 

Warrior

Senior Member
Joined
Feb 4, 2011
Messages
335
Reaction score
0
Location
Isle of Man
Your Mercedes
E320 CDI 03 (Now changed for Jag XF 3.0D S), & Chrysler Crossfire Roadster 04 (SLK in Drag)
and possibly a faulty ignition key, if you have a spare key try running that for a day.
 


Comand (Europe) Ltd are the leading specialists in supplying and fitting Comand, Linguatronic, Media interface kits, UHI phone, IPod interfaces and much more.
Top Bottom