1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ml270 black smoke

Discussion in 'Engine, Drivetrain, Fuel and Exhaust' started by Adem88, Nov 17, 2012.

  1. Adem88

    Adem88 Active Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Nov 14, 2012
    Location:
    Melbourne, Australia
    Your Mercedes:
    2003 ML 270 CDI
    Hi guys I have a 2003 ml 270 cdi, it was running great until the plastic pipe from the turbo to the airfilter/maf cover split, so I replaced that along with a new maf it was good for about a week and I am noticing black smoke on accelerating it only happens when the turbo kicks in and I can hear the turbo wind up, not a whooshing sound but you can hear the boost, I have checked the hoses/pipes etc but I can't find anything, I have used only genuine parts from mercedes, thanks in advanced also it has done 250000 kms
     
    Last edited: Nov 17, 2012
  2. rpe2

    rpe2 Senior Member

    Messages:
    2,863
    Likes Received:
    2
    Joined:
    Sep 25, 2006
    Location:
    Silchester
    Your Mercedes:
    His: 2018 E220 d; Hers: 2016 SMAX
    Was the maf a cheap ebay one our a genuine one?
     
  3. OP
    Adem88

    Adem88 Active Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Nov 14, 2012
    Location:
    Melbourne, Australia
    Your Mercedes:
    2003 ML 270 CDI
    It's wasn't a eBay one its a pierburg maf made in germany
     
  4. oigle

    oigle Senior Member

    Messages:
    3,044
    Likes Received:
    357
    Joined:
    Mar 15, 2005
    Location:
    Redcliffe, Queensland, Australia
    Your Mercedes:
    Currently 2003 ML270. 2012 Nissan Maxima 250SL.
    if you have definitely checked your hoses for splits (boost hoses), I would next suspect a jammed up EGR and coked up manifold. Common problem with these.
     
  5. OP
    Adem88

    Adem88 Active Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Nov 14, 2012
    Location:
    Melbourne, Australia
    Your Mercedes:
    2003 ML 270 CDI
    I have cleaned the egr didn't help I didn't notice any oil on the side of engine but I did notice the manifold rod has abit of oil/gunk on it
     
  6. oigle

    oigle Senior Member

    Messages:
    3,044
    Likes Received:
    357
    Joined:
    Mar 15, 2005
    Location:
    Redcliffe, Queensland, Australia
    Your Mercedes:
    Currently 2003 ML270. 2012 Nissan Maxima 250SL.
    Pretty normal for the rod to leak a bit. The filth inside the manifold has to be seen to be believed....
    The egr valve can still play up after cleaning. They get marked up a bit and can stick open a bit which causes a severe reduction in oxygen values in the air volume. This in turn causes incomplete burn and black smoke.
    There is a quite simple electronic bypass available that removes the egr from the system completely and prevents any issues with it. See the post by dieselman for details. I did the shunt a year ago and recommend it highly.
    The inlet manifold could really do with a clean out too. It will be very restricted by the gunk buildup.
    Cheers - good to see another Aussie on here!!!!
     
  7. OP
    Adem88

    Adem88 Active Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Nov 14, 2012
    Location:
    Melbourne, Australia
    Your Mercedes:
    2003 ML 270 CDI
    Hey oigle thanks for your input I'm going to try find someone in melbourne to do the egr shunt for me as I'm no good with electronics.. With the shunt mod does the intake manifold butterfly's have to be removed or inlet manifold stays the same
     
  8. stumo

    stumo Senior Member

    Messages:
    420
    Likes Received:
    42
    Joined:
    Sep 4, 2008
    Location:
    VIC, Australia
    Your Mercedes:
    ML270CDI 2002 facelift| Sprinter 316CDI 2003 LWB
    It could also be your manifold flaps. Either way the EGR delete mod is well worth doing first. I've done mine almost a year ago and its been fine. You don't touch the manifold for the shunt, its just hooking up some wires.
     
    Last edited: Nov 18, 2012
  9. OP
    Adem88

    Adem88 Active Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Nov 14, 2012
    Location:
    Melbourne, Australia
    Your Mercedes:
    2003 ML 270 CDI
    Stump thanks for your reply I see you are in vic maybe I can pay you to do the mod?
     
  10. oigle

    oigle Senior Member

    Messages:
    3,044
    Likes Received:
    357
    Joined:
    Mar 15, 2005
    Location:
    Redcliffe, Queensland, Australia
    Your Mercedes:
    Currently 2003 ML270. 2012 Nissan Maxima 250SL.
    As stumo said, make sure your manifold flaps are operating correctly. If the linkage has come off or the flaps are jammed closed, you will get similar issues to yours.
     
  11. OP
    Adem88

    Adem88 Active Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Nov 14, 2012
    Location:
    Melbourne, Australia
    Your Mercedes:
    2003 ML 270 CDI
    How to I check if they are working correctly
     
  12. stumo

    stumo Senior Member

    Messages:
    420
    Likes Received:
    42
    Joined:
    Sep 4, 2008
    Location:
    VIC, Australia
    Your Mercedes:
    ML270CDI 2002 facelift| Sprinter 316CDI 2003 LWB
    Its really difficult to see the flap linkages when I tried on mine, there is a lot of junk packed under and around the manifold.

    I have decided i will just remove the manifold and permanently delete them. Its a big job, I just hope i get round to it before one gets ingested and breaks the engine. Mine has similar k's to yours.

    Im sure we could come to an arrangement if you want me to do the EGR shunt for you. I also have star diagnostics so can check your codes too. I'm in Mount Waverley.
     
  13. mersum1es

    mersum1es Senior Member

    Messages:
    1,958
    Likes Received:
    229
    Joined:
    Sep 25, 2010
    Location:
    Finland
    Your Mercedes:
    W212/-09/350CDI, W219/-07/320CDI, EX:W220/-01/320CDI, EX:W211/-04/320CDI, EX:W210/-01/270CDI
    You can see linkages below the manifold, either below front most cylinder duct or between two rear cylinder manifold ducts. When you rise revs from idle, linkages should move. But manifold can be clogged even flaps are moving. Codes will tell if flap motor is functional at all.

    Like said, remove manifold, clean it, remove flaps, disable egr, and have a happy miles.
     
  14. OP
    Adem88

    Adem88 Active Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Nov 14, 2012
    Location:
    Melbourne, Australia
    Your Mercedes:
    2003 ML 270 CDI
    Hey stumo thanks for that mate I would appreciate the shunt mod and codes read. Your not that far I'm in essendon pm me a cost and a time when your available. I appreciate it
     
  15. OP
    Adem88

    Adem88 Active Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Nov 14, 2012
    Location:
    Melbourne, Australia
    Your Mercedes:
    2003 ML 270 CDI
    Just checked to see if the rod moves while rising the revs it, and I does freely I did notice the it dosnt stay open whilst revving higer. As soon as you let go of the throttle and blip it again it opens
     
  16. oigle

    oigle Senior Member

    Messages:
    3,044
    Likes Received:
    357
    Joined:
    Mar 15, 2005
    Location:
    Redcliffe, Queensland, Australia
    Your Mercedes:
    Currently 2003 ML270. 2012 Nissan Maxima 250SL.
    That is the way it works. Looking more like an egr problem.
     
  17. OP
    Adem88

    Adem88 Active Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Nov 14, 2012
    Location:
    Melbourne, Australia
    Your Mercedes:
    2003 ML 270 CDI
    thanks for that i have taken the pipe of that connects to the egr and have taken a video the egr valve is opening half way not sure it is normal or not and you can also see the manifold rod working, (sorry about the no sound) . the egr was cleaned out about 150kms ago. i dont have any oil leaks aswell and my fuel consumption is so bad, (need to change thermostat aswell)

    Here is the video i just made
    http://www.youtube.com/watch?v=PqOemY2rZ70&feature=youtu.be
     
    Last edited: Nov 19, 2012
  18. oigle

    oigle Senior Member

    Messages:
    3,044
    Likes Received:
    357
    Joined:
    Mar 15, 2005
    Location:
    Redcliffe, Queensland, Australia
    Your Mercedes:
    Currently 2003 ML270. 2012 Nissan Maxima 250SL.
    Good little vid. Certainly working. Take the opportunity offered by stumo. He can advise once the codes have been read.
     
  19. OP
    Adem88

    Adem88 Active Member

    Messages:
    31
    Likes Received:
    0
    Joined:
    Nov 14, 2012
    Location:
    Melbourne, Australia
    Your Mercedes:
    2003 ML 270 CDI
    Did you notice the little bit of black smoke coming from the pipe that connects to the egr
     
  20. oigle

    oigle Senior Member

    Messages:
    3,044
    Likes Received:
    357
    Joined:
    Mar 15, 2005
    Location:
    Redcliffe, Queensland, Australia
    Your Mercedes:
    Currently 2003 ML270. 2012 Nissan Maxima 250SL.
    No - not clear enough. Not surprised that a bit of black smoke might come from there. if that is the big pipe from the heater/cooler matrix. Direct connection to the exhaust.
     

Share This Page