Possible MAF problems

kevcooney

New Member
Joined
Nov 22, 2009
Messages
3
Reaction score
0
Your Mercedes
cclass coupe c200k
Hello
I've been looking on the MB forum and the MAF failure matches some of my problems, loss in power, feeling of delay in gear changes.... I popped the car into the local garage and they drove it round and everything seemed fine...they also plugged it in and found no fault errors..
wouldnt this have shown up as a fault?

Everything seemed fine and again today the car just lost power.. my foot was to the floor and the cars speed increased at a very slow pace. somtimes it revs high before kicking in... i can drive around for hours before it happens again.
 

47p2

Senior Member
Joined
May 3, 2006
Messages
3,582
Reaction score
4
Location
Scotland
Your Mercedes
Slk
A MAF doesn't always show up as a fault. Try unplugging it to see if it drives any better. Remember the idle will not be good with it unplugged
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
332
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Yes the MAF for sure Ebay versions are no good a Bosch service center is the cheapest
 
OP
K

kevcooney

New Member
Joined
Nov 22, 2009
Messages
3
Reaction score
0
Your Mercedes
cclass coupe c200k
  • Thread Starter
  • Thread starter
  • #4
just to say thanks.. driving like a dream with the new MAF installed :)
 


Over 100 branches Nationwide, More than 114,000 Parts in Stock, The UKs Largest, and Fastest Growing Parts Supplier,please see MBO Members’ Area for discount codeEuro Car Parts Ltd
Top Bottom