1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

W210 220cdi 2000 heater problems

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by bobef, Dec 21, 2016.

  1. bobef

    bobef New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Dec 21, 2016
    Location:
    London
    Your Mercedes:
    E Class 220 2000
    Greetings. My Mercedes has a heater that is only giving out very 'tepid' heat.
    My mechanic has been looking at the problem.
    He has checked the thermostat - that is fine.
    He has checked the DuoValves (knackered and to be replaced - is it worth getting one from a breakers ? )
    He states they are jammed open so that should mean maximum heat into the cabin??
    He has run some degunking agent through thinking there might be problems in the matrix. This has made no difference.
    He thinks the heater Matrix needs replacing? Job and a half. How likely is that to be so badly blocked as to need changing?
    The car has climate control.
    I have read loads of stuff on the Forum here and come across mention of Flap problems.
    Can anybody please tell me if my problem might be with the Flaps?

    If anybody can offer any guidance i would be very grateful. The though of the dash coming out is scarey - but coming out without need is even worse.

    Happy Christmas - BRRRRRRRRR
     
  2. bob 6600

    bob 6600 Senior Member

    Messages:
    2,353
    Likes Received:
    361
    Joined:
    Dec 21, 2010
    Your Mercedes:
    Audi S8 V10, S210 E320 CDI (R.I.P.)
    I replaced mine with a 2nd had unit no problem
     
  3. mersum1es

    mersum1es Senior Member

    Messages:
    1,952
    Likes Received:
    228
    Joined:
    Sep 25, 2010
    Location:
    Finland
    Your Mercedes:
    W212/-09/350CDI, W219/-07/320CDI, EX:W220/-01/320CDI, EX:W211/-04/320CDI, EX:W210/-01/270CDI
    Last edited: Dec 21, 2016
  4. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    308
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    You can feel the pipes, the ones going into the duo valve should be hot, and with the heater controls set to max heat there should be hot 2 pipes going into the car, you can also measure the voltage on the two outer pins.
     
  5. om613

    om613 Senior Member

    Messages:
    1,428
    Likes Received:
    309
    Joined:
    Aug 29, 2015
    Location:
    london
    Your Mercedes:
    S202 C250TD, S123 240TD
    Occam's. Likely it's the duo valve.
    These cars don't block the matrix in normal use...(which excludes K-Seal / egg whites fixes).
     
  6. mercedes13156

    mercedes13156 Senior Member

    Messages:
    1,259
    Likes Received:
    209
    Joined:
    Dec 27, 2005
    Location:
    West Lothian
    Your Mercedes:
    CLK 200 Cabrio and a Ford Kuga
    Same as on another post today. Have you taken the cabin filter out? I've had the same problem - no heat. The cabin filter was completely choked, never having been replaced from new. Filter in bin = working heater.
     
  7. OP
    bobef

    bobef New Member

    Messages:
    2
    Likes Received:
    0
    Joined:
    Dec 21, 2016
    Location:
    London
    Your Mercedes:
    E Class 220 2000
    Thanks for all your help

    Will check out cabin filter post Xmas
     

Share This Page