2002 ML270 Key re-sync

bloobloo

Active Member
Joined
Oct 23, 2016
Messages
42
Reaction score
0
Location
Ashton in Makerfield, Nr Wigan.
Your Mercedes
ML270 CDI 2002
Hi again.
Well today I replaced my key fob case with a shiny new one. I took the battery cover off, opened the case, took my board and chip out, placed everything into the new case and fastened it all back together.

Pressed the unlock button and nothing. so searched how to re-sync the remote.

I have tried everything! tried the turn to pos. 2 then take key out, press lock and keep pressed whilst pressing unlock 5 times then press tailgate

Tried allsorts of combinations of the above process but still nothing.

The fob worked absolutely fine this morning before I swapped the cases over / took batteries out.

Looked on actual data on iCarsoft in the AAM and it says only key 2 is sync'd

I only have the one key for the car, no idea whenther the key I have is number 2 or 200!
I've tested the batteries with a volt meter and they are fine, even tried replacing the batteries just in case but still nothing.

I must be doing something wrong but I dunno what.
Help!
 
Last edited:

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
You might have knocked on of the sensor off the PCB, the are only about 2mm square. I can probably fix it, but it would take a few days in the post.
 
OP
B

bloobloo

Active Member
Joined
Oct 23, 2016
Messages
42
Reaction score
0
Location
Ashton in Makerfield, Nr Wigan.
Your Mercedes
ML270 CDI 2002
  • Thread Starter
  • Thread starter
  • #3
Thanks for the reply TV, where is the sensor located and I will look for any damage. only trouble is I can't be without the key for a while as I need to use the car, and this is my only key. I am pretty good with a soldering iron, but don't have an infa red system or anything though.
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
Take a look on the PCB there is a little white sensor on the thin end, one each side.
 

Attachments

  • Picture 610.jpg
    Picture 610.jpg
    45.2 KB · Views: 24
  • Picture 609.jpg
    Picture 609.jpg
    58.3 KB · Views: 21

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I do not have a picture of that one.

Is it the locking or the starting of the car that is the problem.
 
OP
B

bloobloo

Active Member
Joined
Oct 23, 2016
Messages
42
Reaction score
0
Location
Ashton in Makerfield, Nr Wigan.
Your Mercedes
ML270 CDI 2002
  • Thread Starter
  • Thread starter
  • #8
It's the remote locking / unlocking. Car starts fine, it's just that I now have to use the key to open the door, then press the lock/unlock in centre console for the rest of the doors / boot. I have tried the re-sync procedure but nothing has worked so far. There must be something I'm not doing right!
 
OP
B

bloobloo

Active Member
Joined
Oct 23, 2016
Messages
42
Reaction score
0
Location
Ashton in Makerfield, Nr Wigan.
Your Mercedes
ML270 CDI 2002
  • Thread Starter
  • Thread starter
  • #9
Think I've found the problem.
Pic 1 left hand side of the board, halfway up. I've looked at it uder the microscope and its squished / melted.
Does anyone know what it is then I can order the bit and fit it?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
In your case I would check the battery connections now I know what key you have. the car starting does not use the batteries.
 
OP
B

bloobloo

Active Member
Joined
Oct 23, 2016
Messages
42
Reaction score
0
Location
Ashton in Makerfield, Nr Wigan.
Your Mercedes
ML270 CDI 2002
  • Thread Starter
  • Thread starter
  • #13
In your case I would check the battery connections now I know what key you have. the car starting does not use the batteries.

I think I may have found the reason why it's not working TV, if you look at pic 1 on the left hand side, roughly halfway up, just to the side of the microswitch is a broken component. I'm trying to find out what component that is, is it a surface mounted fuse or resistor etc, and if so what rating. Then I can source the correct part, and solder it in place, hopefully fixing my problem.
 

Ken_R

Senior Member
Joined
Dec 11, 2015
Messages
691
Reaction score
202
Location
Worcestershire, UK
Your Mercedes
W203 2006 C230 Estate
It looks like a ceramic capacitor,

resin-dipped-ceramic-022uf-capacitor.jpg


but as to what value.........?
 

EmilysDad

Senior Member
Joined
May 8, 2012
Messages
10,315
Reaction score
3,671
Location
Bury Lancs
Your Mercedes
ML350
you sure the battery went back in the right way round when you replaced it Mike? :-? Seems a coincidence that it no longer works afterwards
 
OP
B

bloobloo

Active Member
Joined
Oct 23, 2016
Messages
42
Reaction score
0
Location
Ashton in Makerfield, Nr Wigan.
Your Mercedes
ML270 CDI 2002
  • Thread Starter
  • Thread starter
  • #17
It's definately a surface mounted something or other! There are no legs like a normal capacitor, I have found 3 old keys from old vehicles but none are the same.
I need to pillage an old merc flip key to salvage the right part i think. Trouble is I aint got one lol

Hi Andy, I deffo put the batteries in the right way, There's a + sign inside the back plastic.

I'm tempted to bridge a single strand of wire accross the terminals, but I fear the resistance will be too low and I'll end up frying something else :-?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
331
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
I think that you should buy a secondhand one on Ebay the same and swap the part over.

You can lock the car with the metal blade for now and the car drives.

Do not short that part out.
 
OP
B

bloobloo

Active Member
Joined
Oct 23, 2016
Messages
42
Reaction score
0
Location
Ashton in Makerfield, Nr Wigan.
Your Mercedes
ML270 CDI 2002
  • Thread Starter
  • Thread starter
  • #19
I have been looking on Ebay for another fob, but as usual when I'm looking for a part - none available! hundreds of 2 button ones though.
 

John Laidlaw

Senior Member
Joined
Nov 15, 2013
Messages
26,374
Reaction score
9,064
Location
Wirral
Your Mercedes
BMW 530d X Drive Tourer M Sports
I know this is a minor point but that battery looks like it's got el cheapo Chinese writing on - always use Varta or Panasonic or known genuine brands ( not pound shop specials) - otherwise they will fail in days sometimes hours!
 

Avantgarde Automotive, Mercedes-Benz and SLR McLaren specialists. Service, repairs, diagnosis and motorsport preparation.
Unit 14 Hither Green Trading Estate, Clevedon, Somerset, BS21 6XU Tel: 01275 217270 Email:steve@avantgarde-automotive.co.uk
www.avantgarde-automotive.co.uk
Top Bottom