Camshaft Actuator Malfunction

delboyuk2508

Senior Member
Joined
Dec 10, 2011
Messages
122
Reaction score
0
Location
Torbay
Website
derekpayne.zeekrewards.com
Your Mercedes
C180 2.0ltr 2002
Since doing my headgasket I have had the engine light come on twice, once just after I started the engine up after replacing the headgasket, and there were several faults in memory, which I cleared, and once today, on both occasions the "camshaft actuator malfunction" was in the memory, I have checked the connection and there was evidence of oil ingress into the socket, I have cleaned it up and will see if it settles down.

I would assume that the oil has got into the socket as the actuator was lying down in front of the engine whilst the surgery was taking place, I would also assume that if it does it again I am going to need a new actuator as oil should not be getting into that socket?
 
Last edited:
OP
delboyuk2508

delboyuk2508

Senior Member
Joined
Dec 10, 2011
Messages
122
Reaction score
0
Location
Torbay
Website
derekpayne.zeekrewards.com
Your Mercedes
C180 2.0ltr 2002
  • Thread Starter
  • Thread starter
  • #2
The same message keeps coming up every other day or so, is the camshaft advance mechanism servicable? Or if I disconnect the electrical plug will it stop flagging the message up, yeah I know I could lose some power?
 

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,073
Reaction score
341
Age
87
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
It needs a techie for this one, lets hope that you get a reply
 

WG M-B

Senior Member
Authorised Forum Supporter
Joined
Dec 5, 2010
Messages
3,105
Reaction score
6
Location
North west london
Your Mercedes
C63 Wagon in black
When you refitted the chain was the variator gear turned fully clockwise before connecting the chain to the gear?
 

grober

Senior Member
Joined
May 15, 2002
Messages
2,946
Reaction score
27
Location
Scotland
Your Mercedes
W204 C200cdi estate
There's the ACTUATOR SOLENOID electrical connection and the camshaft position sensor. Check that the electrical connections are good in both.
 
OP
delboyuk2508

delboyuk2508

Senior Member
Joined
Dec 10, 2011
Messages
122
Reaction score
0
Location
Torbay
Website
derekpayne.zeekrewards.com
Your Mercedes
C180 2.0ltr 2002
  • Thread Starter
  • Thread starter
  • #6
When I refitted the camshaft etc I made sure that the inlet cam was set in the retarded position.

There is a tapping noise appeared recently sounds like a loose tappet, havn't checked yet to see where its coming from, but looking at other posts about camshaft actuators would suggest that it is at fault as they have had the same symptoms, I will check and report back on that one
 
OP
delboyuk2508

delboyuk2508

Senior Member
Joined
Dec 10, 2011
Messages
122
Reaction score
0
Location
Torbay
Website
derekpayne.zeekrewards.com
Your Mercedes
C180 2.0ltr 2002
  • Thread Starter
  • Thread starter
  • #7
Just checked and cleared the fault code, and it wasn't the camshaft actuator this time but:

"P0410 - Secondary air injection system malfunction"

Anyone know what that is please?
 

WG M-B

Senior Member
Authorised Forum Supporter
Joined
Dec 5, 2010
Messages
3,105
Reaction score
6
Location
North west london
Your Mercedes
C63 Wagon in black
The dreaded secondary air injection malfunction. This can be caused by blocked air nozzles/ failed secondary injection valve/ patially blocked feed pipe/ failing air recirculation flap/ bad soldered joint in the wiring loom
 
Top Bottom