1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Daney In Distress!

Discussion in 'Introduce yourself' started by Alexadaney, Jan 13, 2020.

  1. Alexadaney

    Alexadaney Member

    Messages:
    15
    Likes Received:
    10
    Joined:
    Jan 13, 2020
    Location:
    Bedford
    Your Mercedes:
    2010 Mercedes C200 CDI
    Hi Everyone!

    I have owned my C200 since April 2019 and it has not skipped a beat. I brought it on 102k on the clock and full service history. I had to get some work done to it along with a relationship break up and moving house, moved jobs, lost the key so had to get a new one ect It's been a tough year! so she was off the road for a good 6 months. I finally have her back YAY!!! Shes as she used to be apart from...my blowers have stopped working :(! I get hot air being pushed through when in transit but no setting is actually blowing air, i've check all fuses ect. but can't find anything wrong, I've found the blower motor ect under the glove box but unfortunatly I am not that great at these kinda things! (even though i've worked for Ford and Audi as a SA for years!) Does anyone have any pointers for me? It's soooo cold in Jan in the UK :(

    Also I don't think my Headunit software is up to date, I'm unable to get onto the AUX option...I have had it working many moons ago but it wasn't that important to me then as I had another car to use at the time. It's not got SATNAV or anything like that it's quite basic.

    If you need anymore info please just let me know and I'll do my best.

    Many thanks!!

    Alexa
     
    Last edited: Jan 13, 2020
  2. dry run

    dry run Senior Member

    Messages:
    990
    Likes Received:
    662
    Joined:
    Aug 1, 2014
    Location:
    Portsmouth
    Your Mercedes:
    2013 C207 E 350 CDi Coupe
    Sorry I can't help you but welcome to the forum and good luck :)
     
    Alexadaney likes this.
  3. OP
    Alexadaney

    Alexadaney Member

    Messages:
    15
    Likes Received:
    10
    Joined:
    Jan 13, 2020
    Location:
    Bedford
    Your Mercedes:
    2010 Mercedes C200 CDI
    Pic attached!
     

    Attached Files:

    Wighty likes this.
  4. EmilysDad

    EmilysDad Senior Member

    Messages:
    8,179
    Likes Received:
    1,919
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    ML350
    Is the fan just seized due to being stood? EmilysMum's car suffered a seized fan due to water ingress but I managed to get my hand in to turn it .... sorted! :)
     
    Alexadaney and Blobcat like this.
  5. Blobcat

    Blobcat Moderator

    Messages:
    18,607
    Likes Received:
    5,814
    Joined:
    Feb 8, 2006
    Location:
    Near Grange Moor (not Wakefield...)
    Your Mercedes:
    R171 SLK280 3.0, Land Rover 110 County SW
    Hello and Welcome,

    Yellow number plate should be on the back :D
     
    Alexadaney likes this.
  6. Blobcat

    Blobcat Moderator

    Messages:
    18,607
    Likes Received:
    5,814
    Joined:
    Feb 8, 2006
    Location:
    Near Grange Moor (not Wakefield...)
    Your Mercedes:
    R171 SLK280 3.0, Land Rover 110 County SW
    Spray of silicone oil on the bearings can keep them going for a good while - my old VW Caravelle used to whine a bit, quick spray and another 6-9 months of silent operation :)
     
    Alexadaney likes this.
  7. OP
    Alexadaney

    Alexadaney Member

    Messages:
    15
    Likes Received:
    10
    Joined:
    Jan 13, 2020
    Location:
    Bedford
    Your Mercedes:
    2010 Mercedes C200 CDI
    Hi EmilysDad,

    Thanks for the suggestion! That could well be it, (a lot cheaper than replacing the unit) I will have to give a go, were you able to do this from under the glove box or did you have to remove anything?

    Thanks again!
     
  8. OP
    Alexadaney

    Alexadaney Member

    Messages:
    15
    Likes Received:
    10
    Joined:
    Jan 13, 2020
    Location:
    Bedford
    Your Mercedes:
    2010 Mercedes C200 CDI

    Hi Blobcat,

    LOL thanks for pointing that out! Just wanted to cover my plate, silly me haha

    have to check my grandads workshop or batt my eyelashes at the lads at a shop, Ill give that a go!

    Thanks!
     
  9. EmilysDad

    EmilysDad Senior Member

    Messages:
    8,179
    Likes Received:
    1,919
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    ML350
    Her car is a Citroen but I managed to just get my fingers to the fan from under the bonnet via the pollen filter housing.
     
    Alexadaney likes this.
  10. OP
    Alexadaney

    Alexadaney Member

    Messages:
    15
    Likes Received:
    10
    Joined:
    Jan 13, 2020
    Location:
    Bedford
    Your Mercedes:
    2010 Mercedes C200 CDI
    Thanks EmilysDad, I'll give it a go when I get home from work. Appreciate it! x
     
    EmilysDad likes this.
  11. SmartAmg

    SmartAmg Senior Member

    Messages:
    3,263
    Likes Received:
    1,457
    Joined:
    May 19, 2018
    Your Mercedes:
    2011 E class coupe 350 CDI
  12. LostKiwi

    LostKiwi Senior Member

    Messages:
    21,068
    Likes Received:
    10,607
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    Hi and welcome
     
    Alexadaney likes this.
  13. mioba

    mioba Senior Member

    Messages:
    1,039
    Likes Received:
    176
    Joined:
    Feb 19, 2006
    Location:
    Nottingham
    Your Mercedes:
    W124/1994/E200, W220/2004/S320CDI, W205/2016/C200, W447/2017/3.0 CDI
    Has the car got AC, the gas could have leaked due to non use and you could have lost lubricating properties somewhere in the AC circuit.

    As a first, do as above, you found the blower, are you hany with a multimeter, check if there is V going to it, if Y, spin it hand and get some lube on there. take it one step at time.

    Things will only get better this year!!
     
  14. AMGeed

    AMGeed Senior Member

    Messages:
    6,060
    Likes Received:
    2,149
    Joined:
    Jan 18, 2009
    Location:
    Poole, Dorset
    Your Mercedes:
    2014 W212 E63 Biturbo
    Welcome to the forum Alexa:)
     
    Alexadaney likes this.
  15. Blobcat

    Blobcat Moderator

    Messages:
    18,607
    Likes Received:
    5,814
    Joined:
    Feb 8, 2006
    Location:
    Near Grange Moor (not Wakefield...)
    Your Mercedes:
    R171 SLK280 3.0, Land Rover 110 County SW
    Should be “Alexa, Welcome to the forum” :D
     
    Flyinspanner, Alexadaney and AMGeed like this.
  16. OP
    Alexadaney

    Alexadaney Member

    Messages:
    15
    Likes Received:
    10
    Joined:
    Jan 13, 2020
    Location:
    Bedford
    Your Mercedes:
    2010 Mercedes C200 CDI

    Hi!

    I've checked all fuses with multimeter hoping it was just a blown fuse. AC doesn't give me cold air and it needs regassing/new condenser

    Will I have to take the motor out to manually spin it?

    Thank you for your suggestions, i'll give an update when i've had a chance to get under the glove box, currently helping my grandad with redoing our bathroom!
     
    Last edited: Jan 14, 2020
  17. EmilysDad

    EmilysDad Senior Member

    Messages:
    8,179
    Likes Received:
    1,919
    Joined:
    May 8, 2012
    Location:
    Bury Lancs
    Your Mercedes:
    ML350
    Hopefully not as it seems these days that they start building a car with the fan motor & build everything else around it. I managed to reach in through the air intake under the wiper scuttle and I have spade like hands :D
     
    Alexadaney likes this.
  18. John Laidlaw

    John Laidlaw Senior Member

    Messages:
    21,988
    Likes Received:
    6,325
    Joined:
    Nov 15, 2013
    Location:
    Wirral
    Your Mercedes:
    UnMercs BMW i8 Volvo XC90
    Alexa........welcome!
     
    Alexadaney likes this.
  19. mioba

    mioba Senior Member

    Messages:
    1,039
    Likes Received:
    176
    Joined:
    Feb 19, 2006
    Location:
    Nottingham
    Your Mercedes:
    W124/1994/E200, W220/2004/S320CDI, W205/2016/C200, W447/2017/3.0 CDI
    Check first if it needs a new condensor (due to leak) then it will need a regas anyway. so be sure if its a leak in the condesor, get that fixed first and take it from there. You motor might not spin if there is no gas due to signals from the ac circuit. I would be surprised a 2010 car has a failed condensor.
    My w220 has had one regas in 16 years so you may be due.

    Once you find the motor you will be able to betwemine if needs coming out, again I doubt the motor at that age of car and given what you saod about the regas, condensor.
     
    Alexadaney likes this.
  20. LostKiwi

    LostKiwi Senior Member

    Messages:
    21,068
    Likes Received:
    10,607
    Joined:
    Aug 25, 2006
    Location:
    Midlands / Charente-Maritime
    Your Mercedes:
    '93 500SL-32, '01 W210 Estate E240, 02 R230 SL500 (Malcolm Spec), 04 Smart Roadster Coupe
    A/C won't operate unless the fan motor is going. Get that sorted first before looking at A/C.
     
    Alexadaney likes this.

Share This Page