1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Heater/blower motor failed

Discussion in 'Electrics, Vacuum, Ignition and ECU' started by ODDBALL500, Oct 20, 2011.

  1. ODDBALL500

    ODDBALL500 Member

    Messages:
    20
    Likes Received:
    0
    Joined:
    Oct 20, 2011
    Location:
    Cornwall
    Your Mercedes:
    C250 Sport 2.5l Turbo Diesel
    Hi all,
    I washed my C250 last Sunday after owning her for 1 week and jet washed the area under the windscreen wipers to remove leaves, I then found water inside the driver foot well, this has not happened when it's rained so I presume it somehow got in through the vents, the windows were steamed up so I turned the fan on to clear the windscreen but the fan did not work, it had previously with no problems, I checked all the fuses and all okay, it's been 5 days now and I was hoping it would dry out and work but no joy, can anyone confirm if the motor is up under the passenger foot well, I have removed the cover underneath but cannot see it easily, has anyone else had this issue or any other advise on fixing this problem, your help will be very much appreciated.

    Simon
     
  2. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    293
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    It is up there and I have answered you other post
     
  3. OP
    ODDBALL500

    ODDBALL500 Member

    Messages:
    20
    Likes Received:
    0
    Joined:
    Oct 20, 2011
    Location:
    Cornwall
    Your Mercedes:
    C250 Sport 2.5l Turbo Diesel
    Sorry to seem a bit thick, when you say you answered my other post, where is this reply, as previously said I'm new to this stuff

    Simon
     
  4. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    293
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    Maybe its me,,, anyway I can send you the instructions
     
  5. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    293
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    It should be under the drivers side as the heater boxes are not handed
     
  6. OP
    ODDBALL500

    ODDBALL500 Member

    Messages:
    20
    Likes Received:
    0
    Joined:
    Oct 20, 2011
    Location:
    Cornwall
    Your Mercedes:
    C250 Sport 2.5l Turbo Diesel
    Hi Malcolm, thanks so far for all your help, please can you send the instrctions to my work email address which is



    Simon
     
    Last edited: Oct 20, 2011
  7. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    293
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded
    OK I have sent it and you can remove your address in edit
     
  8. OP
    ODDBALL500

    ODDBALL500 Member

    Messages:
    20
    Likes Received:
    0
    Joined:
    Oct 20, 2011
    Location:
    Cornwall
    Your Mercedes:
    C250 Sport 2.5l Turbo Diesel
    Hi Malcolm, Thank you again for your help, I removed the blower which was very mucky and thought "well it aint working" so I washed it in hot soapy water and dried it overnight on the radiator & re-connected it this afternoon and hey presto she lives, my girlfriend will be very happy as she can have toastie feet again lol

    I owe you a few beers sometime if you're ever in the Perranporth area in Cornwall LOL

    Si
     
  9. television

    television Always remembered RIP

    Messages:
    164,074
    Likes Received:
    293
    Joined:
    Mar 14, 2005
    Location:
    Daventry
    Your Mercedes:
    2002 SL500, 216 CL500, all fully loaded

    I am just happy that all is OK :D:D
     

Share This Page