It is official, I screwed my c270cdi gearbox - HELP

fjmrf

New Member
Joined
Feb 8, 2013
Messages
7
Reaction score
0
Location
London
Your Mercedes
C270cdi 2001 2700cc
Hi everyone.
Well, it is true... I just screwed the gearbox and I need help:
The case: my gearbox, after get in the right temperature, was getting in limb/safe mode when you press the gas hard... Sometimes even slipping to neutral.
So I checked in a mb scanner and it was a sensor in sensor plate, but the mechanic told me that "could" be only the fluid (it was yellow, old, car with 96k)... Trying to economise a few bucks (stupid decision) I decided to change the oil by myself...
I've a got knowledge about cars (already assembled few engines, I put a turbo in my car by myself, etc) but no knowledge about automatic gearbox...
I read some forums and decided to do... After all, "how hard can it be?"...
It drains only 2 litres by the drain screw. So I decieded to buy the original oil (6 litres) and do 3 changes, knowing that part of the oil would be the old but it could solve the problem.
First time ok, second time I got the "brilliant" idea of turn the car on for a second to take a bit more oil out... Worked, 3 litres... I bought another litre. The car was "ok" until now but with the slip gear problem...
In the third time I did as the second one, this time only 2 litres...
The car has keeped slipping the gears but now with a small repetitive noise when rolling (not from engine, noise change with speed, not rpm)... I was think in wheal bearing...
Today I was going out and the car was completely without power when starts... You accelerate and it almost don't move... Almost 1 minute after turned on it started to work well, but when I put the car in the road the noise was really ugly (how faster it goes more noise it does)...

Well, that is the case in bad English (sorry, I'm a Portuguese speaker living in London)... The money is short and I know that I will need to take to the garage to fix it (or someone want want to buy a 2001 c270cdi in great shape but with a big problem in the gearbox????)
I believe that will be better buy a new gearbox and put it on place... And here are 2 questions:
1st: I know that the 722.6 gearboxes have different ending numbers depending of car model. Anyone knows what one works with my car? (e.g.: will a c220cdi gearbox works in my car?)
2nd: anyone has this gearbox to sell me or know someone / someplace where I can buy (cheap, please!!!!)?

:fail

Thanks
 

Frontstep

Senior Member
Joined
Apr 22, 2007
Messages
7,879
Reaction score
1,688
Your Mercedes
T210 320cdi
Wait for some one with more knowledge than me but i don't think you have made anything worse from what you describe having done.
It sounds like you need your car on Star before doing anything else.
 

panason1c

Senior Member
Joined
Apr 19, 2004
Messages
1,927
Reaction score
6
Age
67
Location
Somerset, UK
Your Mercedes
Mercedes ML270CDI, VW Polo 1.9tdi, BMW K1200RS
I would remove the gearbox sump and fit a new oil filter, the old one might be obstructed with a build up of debris/sludge which would cause oil starvation to the gearbox.
 

mersum1es

Senior Member
Joined
Sep 25, 2010
Messages
2,109
Reaction score
305
Location
Finland
Your Mercedes
W212/-09/350CDI, W219/-07/320CDI, EX:W220/-01/320CDI, EX:W211/-04/320CDI, EX:W210/-01/270CDI
Oil filter change is good idea, did you check the oil level with proper temperature? Sound that you may have wrong amount of oil now... 5 speed box is not so sensitive than 7-speed, but sometimes right oil level may help.

IF your mech was reading codes and speed sensor of sensor plate was giving code, it may be now totally broken and that causes box safe mode. You'll need to change that as well when you remove the bottom of the oil sump. Refurbished sensor plates/hydraulic units are available. Start with code reading like suggested!
 
Last edited:

television

Always remembered RIP
Joined
Mar 14, 2005
Messages
164,074
Reaction score
330
Age
86
Location
Daventry
Your Mercedes
2002 SL500, 216 CL500, all fully loaded
How are you checking the level, some thing very wrong if only getting 2 litres out, it should be 4 litres with 3½ left in the converter and cooler
 
A

andy@pcd-ltd

Guest
Also what oil did you put in it ,where did you buy it from.

Where did you poor the oil back in to.
 
OP
F

fjmrf

New Member
Joined
Feb 8, 2013
Messages
7
Reaction score
0
Location
London
Your Mercedes
C270cdi 2001 2700cc
  • Thread Starter
  • Thread starter
  • #7
The "lion" problem was a "cat"...

Hi everyone... Thanks for the replay. I've been in the garage today. Good news and bad news:
Good news:
I did the change right (considering that I didn't open the gearbox it is around 2-3 litres only) and my change didn't screwed.
The noise was the parking brake cable that was touching the drive shaft... A support broke and it fall over... Probably by chance it brakes at same time that I was servicing the gearbox... That's why the noise was only inside, the cable was vibrating and the sound was loud only inside...
The lack of power was probably due to air in the system because I make the system work without oil for few seconds (not enought to break or damage but enought to put air in the system). Today worked 100%.
Bad news: :crazy:
The problem of my car IS the sensor plate... ( not so bad if considering the previous panorama). But it is only this...
I've learned a lot today, expended 50 bucks with the garage to elevate the car properly and solving this minor issues but in the end is everything ok... I fell 20 pounds light!!!

Thanks all for the replay. :D:D
 

Vamps

Active Member
Joined
Apr 4, 2012
Messages
33
Reaction score
0
Location
Durham
Your Mercedes
Jeep Grand Cherokee
Hi everyone... Thanks for the replay. I've been in the garage today. Good news and bad news:
Good news:
I did the change right (considering that I didn't open the gearbox it is around 2-3 litres only) and my change didn't screwed.
The noise was the parking brake cable that was touching the drive shaft... A support broke and it fall over... Probably by chance it brakes at same time that I was servicing the gearbox... That's why the noise was only inside, the cable was vibrating and the sound was loud only inside...
The lack of power was probably due to air in the system because I make the system work without oil for few seconds (not enought to break or damage but enought to put air in the system). Today worked 100%.
Bad news: :crazy:
The problem of my car IS the sensor plate... ( not so bad if considering the previous panorama). But it is only this...
I've learned a lot today, expended 50 bucks with the garage to elevate the car properly and solving this minor issues but in the end is everything ok... I fell 20 pounds light!!!

Thanks all for the replay. :D:D

Result......:)
 


The SL SHOP YOUR ONE STOP SHOP FOR ALL THINGS SL, SERVICE & RESTORE, SALES, HIRE & PARTS
Choose from a wide range of superbly prepared SL’s each with a 12 month guarantee. We can service, update, re-trim, restore and repaint your 107 SL.
Choose from a 6 or 8 cylinder car for the day, the weekend, a month or a year. Contact us for a wide range of parts. Tel: 0844 414 2116 or visit our website atwww.theSLshop.com
Top Bottom