My remote can't function-please help

Shukri

New Member
Joined
Oct 1, 2020
Messages
4
Reaction score
0
Your Mercedes
W211 2004 E240
Hey guys, my W211 remote keys works just fine when start engin, lock and unlock all doors. But when parking for an hour or more, the remote keys cannot open or lock doors. Remote red light still blinks, key fob batteries are good, but no respond from the doors. Need to take out small key to open door. Anybody can help?
p/s, i’ve changed the radio to android player last two days.
 

Wearsafoxhat

Senior Member
Joined
Aug 9, 2011
Messages
2,123
Reaction score
1,874
Location
Sunny Hampshire by the sea
Your Mercedes
E55k :S211, SL500 :R129 , V220
Possibly disconnected the aerial for the remote. Can lock when leaving the car as the system is still awake, but shut down / asleep after an hour.
Has this problem only started since changing the unit ?


Sent from my iPad using Tapatalk
 
OP
S

Shukri

New Member
Joined
Oct 1, 2020
Messages
4
Reaction score
0
Your Mercedes
W211 2004 E240
  • Thread Starter
  • Thread starter
  • #3
Yes, this problem occured after changing the unit. So what is the solution? I’ve tried all day. The fuse also fine. Maybe it connected with the radio antenna?
 
OP
S

Shukri

New Member
Joined
Oct 1, 2020
Messages
4
Reaction score
0
Your Mercedes
W211 2004 E240
  • Thread Starter
  • Thread starter
  • #4
Possibly disconnected the aerial for the remote. Can lock when leaving the car as the system is still awake, but shut down / asleep after an hour.
Has this problem only started since changing the unit ?


Sent from my iPad using Tapatalk

Yes, this problem occured after changing the unit. So what is the solution? I’ve tried all day. The fuse also fine. Maybe it connected with the radio antenna?
 

Wearsafoxhat

Senior Member
Joined
Aug 9, 2011
Messages
2,123
Reaction score
1,874
Location
Sunny Hampshire by the sea
Your Mercedes
E55k :S211, SL500 :R129 , V220
Yes, this problem occured after changing the unit. So what is the solution? I’ve tried all day. The fuse also fine. Maybe it connected with the radio antenna?

I think it will or would have been connected to the antenna. Not sure how you could connect it up though as probably part of the original unit.

I am sure someone will have a definitive answer or solution as many people must have replaced units.

Sent from my iPad using Tapatalk
 
OP
S

Shukri

New Member
Joined
Oct 1, 2020
Messages
4
Reaction score
0
Your Mercedes
W211 2004 E240
  • Thread Starter
  • Thread starter
  • #6
I think it will or would have been connected to the antenna. Not sure how you could connect it up though as probably part of the original unit.

I am sure someone will have a definitive answer or solution as many people must have replaced units.

Sent from my iPad using Tapatalk

thank you so much
 


ALL MBO Club members qualify for 15% discount on second hand parts.Please see MBO Members’ Area for discount codewww.dronsfields.com
Top Bottom